Usb PrePen


I’m using Ubuntu Studio 15.04 on a Lenovo Yoga 2 - which works pretty decent. For speech recording i tried to get Audacity 2.0 working with “m-audio fast track pro” as interface which didn’t work at all. Then i stumbled across this device:
I guess i was already using Audacity 2.1.0 when i got it - it recognized the PrePen but crashed when trying to record under Alsa. I decided to upgrade Audacity to version 2.1.1 via the audacity-repository that is recommended and use Jack as audioserver. Now neither Audacity 2.1.1 (Alsa or Jack) nor QJackctl list the USB-microphone (consisting of the PrePen and a Standard Shure Sm58). It doesn’t make a difference whether i start Audacity or even the OS with the interface connected.

If anybody has any ideas about that problem or finds a similar thread with a solution, please let me know.

Reboot your computer, then connect the PrePen.
Then, in a Terminal window enter:


When Alsa Mixer opens, press the F6 key to list the available devices.
What devices are listed in the blue box?

(press Escape twice to exit Alsa Mixer)

Hi Steve

Thanx for your reply - alsamixer gives me this options:

0 HDA Intel HDMI
1 HDA Intel PCH

I don’t know, if it makes any difference, but just to be shure: I use the 64-bit version of Ubuntu Studio 15.04

Neither of those look likely to be the PrePen. To be sure, repeat the test but without the PrePen connected to your computer. Do you see the same options? If so, then for some reason your PrePen is not being recognised. If the computer does not see the PrePen, then Audacity will not be able to see it.

Things to check if your computer cannot see the PrePen:
Check the USB lead and connections.
Try plugging into a different USB port.
Do not plug in the PrePen via a USB hub.
If possible, try a different USB lead.
If possible, test the PrePen on another computer.

I did repeat the alsamixer-query with the same outcome - I also have tried to find the PrePen before via lsusb and usbview with negative results. I hadn’t used a hub - so that wasn’t the cause - I changed the usb-lead an the ports (the lonovo yoga has one 3.0 and one 2.0 usb). All that didn’t make the device visible.
What puzzles me ist that it was recognized earlier - so of course I tried to figure out what has changed since then.
I used it before on another computer (Zotac Zbox with Ubuntu Studio 14.10 on it) under Alsa. Because the Lenovo didn’t recognize it anymore, I switched to the Zbox again and activated Jack. Then Audacity didn’t find the USB device also on that machine - so I have two different problems on two different computers (that’s mainly why I decided to post ist):

  1. Maybe on the Zbox the activation of Qjackctl blocked the USB permanently
  2. Maybe that also happened on the Lenovo, where it coincided with upgrading to Audacity 2.1.1. because the previous version had crashed as soon i had tried to record via usb using Alsa. Recording via USB ist the only way, where i don’t have a lot of noise on it.

Forget about Jack for now. Jack runs on top of ALSA, so it can only work with a device if that device is working correctly with ALSA.
If you managed to get Jack started, it was probably running with your on-board sound card rather than the USB device - this will only confuse the issue and make fault finding more difficult, so don’t try to run Jack until we have discovered what the current problem with the PrePen is.

Rebooting the computer before running tests is a good idea because it can eliminate possible problems with other active programs being the cause.

Try running (with the PrePen connected):

arecord -l

(that’s a lower-case “L” at the end).
What output do you get?

That leans toward it being a dodgy connection or lead.

With you mic plugged into the PrePen and the input level turned up on the PrePen, do any of the LEDs come on when you talk into the mic?

arecord -l gives me this (“Sub-Gerät” also means subdevice)

**** Liste der Hardware-Geräte (CAPTURE) ****
Karte 1: PCH [HDA Intel PCH], Gerät 0: CX20756 Analog [CX20756 Analog]
Sub-Geräte: 1/1
Sub-Gerät #0: subdevice #0

I also get reactions from the led - so there is a signal from the microphone getting through to the PrePen

I was looking in some ubuntu forums concerning problems with the snd-usb-audio module but didn’t find something helpful. I apprehend that this problem goes deeper and rather concerns Ubuntu Studio - sorry to bother you nevertheless.

It seems that your computer is not seeing the PrePen at all. The only device it can see is the (Conexant) Intel chip on your motherboard.
The device is receiving power via the USB cable (the lights are coming on) but your computer cannot see that there is a USB audio device connected.

My suspicion is that the USB socket on the PrePen may be damaged. I’ve never had much confidence on those mini-USB connectors. However, the problem could still be as simple as a faulty cable. You really need to try the device on another computer with a USB lead that you know is good. If you bought the device from a shop, they may be able to assist.

thank you for all your thought on the subject

I guess, your suspicion points in the right direction - I also don’t have much confidence in the mini-USB solution (at least not in that angle). I just tried to press the lead real tight INTO the socket and the light indicating bus-power flickered. I guess it is a physical problem although the device is new. I’ll go back to trying make the m-audio fast track pro work.

Does it have a guarantee?

fortunately yes (24 months) - but it could take a while until I get a new one and have to get some radio shows pre-produced. so there’s a good chance that in the not too far future (tomorrow for example) there will appear some topic like “problems with m-audio fast track pro”. that’s not meant to sound whiny - i’m a huge fan of the audacity project and using the program since 0.8. i think you guys are doing a great job.