USB Needledrop?

Can anyone tell me how to make a recording of a record from a Crosley Revolution record player via its USB output? I’m very Linux-savvy but I’ve never used Audacity before.

Close Audacity. Plug in the turntable and it should announced itself to the system as a “USB Audio Device” or words to that general effect. Start Audacity and the Device Toolbar should have a listing for that new device. Don’t do that out of order.

After that, it’s regular Audacity. Put a record on and press Record. I don’t know if linux supports volume control or not. Some systems do.


See this set of tutorials from the manual:

especially this one:


Thank you, I got everything set up but when I try to make a recording I get a massive amount of these in dmesg:

[193348.757350] BUG: scheduling while atomic: audacity/2114/0x00000005
[193348.757355] Modules linked in:
[193348.757363] Pid: 2114, comm: audacity Tainted: G W 3.6.0-rc1 #5
[193348.757366] Call Trace:
[193348.757376] [] ? __schedule_bug+0x4b/0x60
[193348.757383] [] ? __schedule+0x501/0x660
[193348.757389] [] ? schedule_timeout+0x135/0x1d0
[193348.757394] [] ? add_timer_on+0x80/0x80
[193348.757406] [] ? wait_clear_urbs+0x42/0x90
[193348.757415] [] ? snd_usb_endpoint_start+0x4c/0x380
[193348.757421] [] ? start_endpoints+0x65/0x80
[193348.757428] [] ? snd_usb_substream_capture_trigger+0x50/0x90
[193348.757441] [] ? snd_pcm_action_group+0x153/0x230
[193348.757446] [] ? snd_pcm_action_group+0x1fd/0x230
[193348.757455] [] ? snd_pcm_action_lock_irq+0x67/0xe0
[193348.757460] [] ? snd_pcm_common_ioctl1+0x21b/0xbb0
[193348.757468] [] ? finish_task_switch+0x57/0xd0
[193348.757473] [] ? __schedule+0x282/0x660
[193348.757477] [] ? snd_pcm_playback_ioctl1+0x42/0x260
[193348.757483] [] ? hrtimer_try_to_cancel+0x3f/0x80
[193348.757489] [] ? snd_pcm_playback_ioctl+0x2d/0x40
[193348.757497] [] ? do_vfs_ioctl+0x96/0x500
[193348.757504] [] ? hrtimer_nanosleep+0xa8/0x170
[193348.757510] [] ? hrtimer_get_res+0x40/0x40
[193348.757519] [] ? sys_ioctl+0x49/0x80
[193348.757524] [] ? system_call_fastpath+0x16/0x1b

Here is my terminal output:

$ audacity
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.rear
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.center_lfe
ALSA lib pcm.c:2217:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.side
ALSA lib pcm_dmix.c:957:(snd_pcm_dmix_open) The dmix plugin supports only playback stream
Expression ‘stream->playback.pcm’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 3875
Expression ‘stream->playback.pcm’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 3875
Expression ‘stream->playback.pcm’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 3875
Expression ‘stream->playback.pcm’ failed in ‘src/hostapi/alsa/pa_linux_alsa.c’, line: 3875

Is this a kernel bug?

I tried kernels 3.4.5 and 3.5.1 and neither produces the error so I guess it’s a kernel bug with 3.6.0-rc1. The sound comes out so low that no waveform is drawn. I can normalize it up but it sounds pretty bad and there is a high-pitched noise over everything which I think is normal computer noise but it’s being normalized way too high along with the audio. Can this be fixed? I don’t think there is a gain control for the USB-out of the Crosley Revolution but I’ve contacted Crosley to find out for sure.

If you’re using a laptop computer, try running on battery power while recording.

I had the same idea and I tried that along with unplugging all other USB devices but the result was the same. The problem seems to be that the gain is way too low which requires cranking everything way up including the noise which should be below the level of audibility. I hear the same noise if I plug headphones into the record player with the USB cable attached and crank the volume all the way up.

I’m trying to plug the line-out of the turntable into my laptop’s combo headphone/mic input but all I can record is my own voice and noises in the room. Audacity only lists one audio device which is HDA Intel. Surely this must be possible since the input works with the microphone on a headset?

Low-Level, delicate, easily damaged, mono Mic-In is very different from High-Level, Robust, Powerful, Stereo, Line-In. You can’t plug one into the other. To get modern PC laptops to record stereo, we have been known to recommend the Behringer UCA202.

However, if nothing you’ve been able to do so far is successful, then the turntable may be broken. This isn’t unusual. USB turntables as a group are throw-away devices. You get to the end of your vinyl and put the whole thing in the trash, so they’re not the highest quality and they’ve been known to come out of the box with problems. Many of them come with Audacity, so we get the fallout.


It’s crappy alright, but it’s portable. I’m going to get a Sony PCM-M10 handheld recorder for this. Thank you for your help.

I don’t understand how a hand-held digital recorder is going to help you get good quality transcriptions of vinyl records. :confused: :confused:

You must be thinking of recording the records from the loudspeakers on your hi-fi system, is that right? If you do that you will also pick up the dog barking, the doorbell ringing, the traffic outside in the street, the low flying aircraft on approach to your local airport, etc., etc… Your recording will still be crappy - just a different kind of crappy - and crappy in a way that cannot be fixed in post-production. If you have a good quality hi-fi system then what you really need is the right “box of tricks” to connect between the hi-fi system’s Line Out and the computer. I think that is what the Behringer box is designed to do - but I know nothing about them except what I have learned from posts on this forum. Before you throw good money after bad, I would wait and see what other responses you get to your suggestion that you buy that Sony device. I’m not sure it is the right solution for your problem.

No, no, the Sony has analog line-in and at 24/96. That would be funny, recording output from the speakers with the handheld. :slight_smile: