USB Mic issues :(

Okay, I’ve been using audicity for a while, I don’t really know how to work it well other than to record, playback and save the files. Today I wanted to record and my mic isn’t working.

I use a Logitech USB microphone like the one here:

It’s always worked before. I know the microphone itself still works because it works in my PS2 still, and I know it’s connected because it shows up in all the settings menus etc. so my best guess is that it’s some sort of setting that I have set wrong.

Pretty much what happens is I hit record, and it “records” but there’s no sound coming in from the mic, the line is just a strait steady line. I can’t hear anything in my speakers either (but I’ve never been able to hear my mic in my speakers). I really want to know how to fix this. The last time I used my mic (3 weeks ago?) it still worked fine. I would appreciate any suggestions.

I don’t think I’ve given very much helpful information so if you need more to help answer my question then please ask and I’ll try to answer to the best of my ability.


Make sure the Mic is selected as the recording source in Audacity’s edit → preferences → audio I/O menu.

If you unplug/replug the mic, it might not reset itself as the default input source in Audacity.