USB connection from turntable to a new iMac

I have a new iMac (all intel) and it does not recognize the USB connection from the turntable (Audio Technica AT-LP120-USB). All that’s available for audio input is the internal mic that comes with the iMac. Anybody else have this problem? Solutions?

Step one is to see if the Mac knows it’s there.

Apple (upper left desktop) System Preferences > Sound > Input.

If it shows up there, Restart Audacity. Audacity automatically checks for new devices when it starts. You can also force a check with Transport > Rescan.

Still stuck?



Thanks. Checked System Preferences, Sound, Input, still on acknowledging the internal mics. Have tried restarting, connecting before restart, after restart, turntable on, turntable off, no luck.

At the risk of gently shifting the buck, if the Mac can’t find it, Audacity will never find it. Are there any lights on the turntable? Is it powered from the USB or does it have its own power cord?

Never mind. It has a power cord. Does it have a USB light?

It’s not unusual for a USB sound device to have an electronic device name miles away from its English name. Could it be there under a different name. “USB Audio CODEC” for example instead of “Audio Technica?”

Use this output to connect your turntable to the USB input of
your computer. Please see included software guide for

The turntable could need software drivers. Did you do that?


Could you please specify which iMac, which OSX and which version of Audacity you are using?

The Audacity version you get with the AT-LP120-USB is an older one. I don’t think that is the problem, but you never know.

Another forum dweller used that turntable with OSX and it works very well. It doesn’t need drivers, since it is USB Audio class compliant.

Also, have you tried another USB port and/or cable?

Also, have you tried another USB port and/or cable?

That’s my guess. If the turntable doesn’t show in System Preferences, it means the turntable isn’t getting to the Mac. You can close Audacity until you get this sorted.

You could have a bad cable or a bad connection on the computer. The turntable could be bad. Any of those will prevent System Preferences from seeing the turntable.

Can you try a different Mac or different computer?