USB Codec Problem

Audacity 2.0.4 (.dmg installer)
Mac OS 10.8.5

Opening Audacity I get an error: “Registry Error, Please insure this product has been installed properly” which hasn’t been a problem until now. I think I read it was probably a plug-in compatibility issue. Now when using the USB Audio Codec there’s an error on playback, " ERROR, Error while opening sound device, Please check output device settings and project sample rate." I double checked the settings. There’s not a problem with recording. Playback works if output is switched to a different device.

I’ve repaired permissions and changed the config file so as not to load the plug-ins but there was no difference. I installed the zip but there was no change.

I also use Reaper and Twisted Wave & they both work fine.

Any suggestions are appreciated. Thanks.


The “Registry Error” is not coming from Audacity so it is almost certainly coming from a plug-in.

Make sure Audacity is quit (Audacity > Quit Audacity) then replace the entire contents of audacity.cfg with this:


There is more help with editing audacity.cfg here: .

What device is the USB Audio CODEC? If it is a USB turntable or USB cassette deck, you cannot use it as a playback device for the computer.


I’ll get to work on this.

Thanks Gale,


Thanks for the Info, should be able to fix it now.

The device is an Allen & Health ZED10FX mixing board. It’s been working well until yesterday when the problem started.


I added the audacity.cfg file and audacity folder to /Library/Applications Support. It didn’t change a thing so I unchecked all of the plug-ins in preferences and re-started Audacity. Didn’t get the Error message as it was starting but that was the only thing that changed. I tried to open a file and it crashed. If I’m reading it correctly it looks like its which is in /Library/Preferences and not a plug-in so I was afraid to delete it & I couldn’t upload it as the plist extension isn’t allowed. Tried to change/add to the extension but the file changed too.

Here’s a part of the report:

Process:         Audacity [44793]
Path:            /Applications/Audacity/
Identifier:      net.sourceforge.audacity
Version: (
Code Type:       X86 (Native)
Parent Process:  launchd [533]
User ID:         501

Date/Time:       2013-09-22 20:55:42.821 -0600
OS Version:      Mac OS X 10.8.5 (12F37)
Report Version:  10

Interval Since Last Report:          217307 sec
Crashes Since Last Report:           203
Per-App Interval Since Last Report:  34614 sec
Per-App Crashes Since Last Report:   9
Anonymous UUID:                      6025215A-760B-0F5A-4124-13DA3E224F38

Crashed Thread:  0  Dispatch queue:

Exception Codes: KERN_INVALID_ADDRESS at 0x000000000b7ffffa

VM Regions Near 0xb7ffffa:
    __LINKEDIT             000000000b771000-000000000b784000 [   76K] r--/rwx SM=COW  /usr/local/lib/audacity/libavformat.52.dylib
    MALLOC_TINY            000000000b800000-000000000b900000 [ 1024K] rw-/rwx SM=PRV  

Thread 0 Crashed:: Dispatch queue:
0   libsystem_c.dylib             	0x958c19db memmove$VARIANT$sse3x + 1917
1           	0x97e4720b CArray::ReplaceElements(long, long, long, void const*) + 125
2           	0x97e6afad CUnicodeTextension::UnicodeReplaceRange(long, long, TReplaceParams const&, unsigned char, unsigned char) + 1873
3           	0x97e6b591 CUnicodeTextension::ReplaceRange(long, long, TReplaceParams const&, unsigned char, unsigned char) + 97
4           	0x97e5d17e CReplaceTextCommand::DoMainAction() + 74
5           	0x97e5c799 CTextensionEditCommand::DoIt(short*) + 25
6           	0x97e5c09e CTextensionCommand::Execute(short*) + 54
7           	0x97e64387 OpaqueTXNObject::ExecuteCurrCommand() + 121
8           	0x97e5f8a5 OpaqueTXNObject::NewCommand(short, AttrObjModifier const*, TKeyDownParams*, TReplaceParams*) + 1065
9           	0x97e55502 DoSetDataCommand(OpaqueTXNObject*, unsigned long, unsigned long, TReplaceParams*) + 314
10           	0x97e54ecd TXNSetData + 1037
11  net.sourceforge.audacity      	0x0043cdc5 wxMacMLTEControl::SetTXNData(wxString const&, unsigned long, unsigned long) + 165
12  net.sourceforge.audacity      	0x0043ced3 wxMacMLTEControl::WriteText(wxString const&) + 195
13  net.sourceforge.audacity      	0x0043cab8 wxTextCtrl::WriteText(wxString const&) + 168
14  net.sourceforge.audacity      	0x004ea4b9 wxLogWindow::DoLogString(wchar_t const*, long) + 137
15  net.sourceforge.audacity      	0x005567e6 wxLog::DoLog(unsigned long, wchar_t const*, long) + 342
16  net.sourceforge.audacity      	0x004ecaa3 wxLogWindow::DoLog(unsigned long, wchar_t const*, long) + 99
17  net.sourceforge.audacity      	0x00037a7b wxLog::OnLog(unsigned long, wchar_t const*, long) + 235
18  net.sourceforge.audacity      	0x00555fe1 wxVLogMessage(wchar_t const*, char*) + 113
19  net.sourceforge.audacity      	0x0055605b wxLogMessage(wchar_t const*, ...) + 27
20  net.sourceforge.audacity      	0x00125f02 Importer::Import(wxString, TrackFactory*, Track***, Tags*, wxString&) + 1794
21  net.sourceforge.audacity      	0x00199aa5 AudacityProject::Import(wxString, WaveTrackArray*) + 149
22  net.sourceforge.audacity      	0x0019da64 AudacityProject::OpenFile(wxString, bool) + 2196
23  net.sourceforge.audacity      	0x000417aa AudacityApp::MRUOpen(wxString) + 410
24  net.sourceforge.audacity      	0x00041ab5 AudacityApp::OnMRUFile(wxCommandEvent&) + 149
25  net.sourceforge.audacity      	0x0059b0e3 wxEvtHandler::ProcessEventIfMatches(wxEventTableEntryBase const&, wxEvtHandler*, wxEvent&) + 115
26  net.sourceforge.audacity      	0x0059b25f wxEventHashTable::HandleEvent(wxEvent&, wxEvtHandler*) + 111
27  net.sourceforge.audacity      	0x0059b62f wxEvtHandler::ProcessEvent(wxEvent&) + 207
28  net.sourceforge.audacity      	0x0059b048 wxEvtHandler::TryParent(wxEvent&) + 56
29  net.sourceforge.audacity      	0x0059b5dc wxEvtHandler::ProcessEvent(wxEvent&) + 124
30  net.sourceforge.audacity      	0x004bba06 wxMenuBase::SendEvent(int, int) + 86
31  net.sourceforge.audacity      	0x004201a8 wxMenu::MacHandleCommandProcess(wxMenuItem*, int, wxWindow*) + 72
32  net.sourceforge.audacity      	0x003e647a wxMacAppEventHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 1050
33           	0x97dad9bb _InvokeEventHandlerUPP(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*, long (*)(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*)) + 36
34           	0x97c35394 DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1343
35           	0x97c34780 SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 430
36           	0x97c48655 SendEventToEventTarget + 88
37           	0x97dad86a SendHICommandEvent(unsigned long, HICommand const*, unsigned long, unsigned long, unsigned char, void const*, OpaqueEventTargetRef*, OpaqueEventTargetRef*, OpaqueEventRef**) + 498
38           	0x97c24984 SendMenuCommandWithContextAndModifiers + 70
39           	0x97c24931 SendMenuItemSelectedEvent + 268
40           	0x97c247b6 FinishMenuSelection(SelectionData*, MenuResult*, MenuResult*) + 134
41           	0x97df9e7e MenuSelectCore(MenuData*, Point, double, unsigned long, OpaqueMenuRef**, unsigned short*) + 623
42           	0x97dfadc6 MenuSelect + 171
43  net.sourceforge.audacity      	0x004481d0 wxMacTopLevelMouseEventHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 1008
44  net.sourceforge.audacity      	0x003e64ba wxMacAppEventHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 1114
45           	0x97dad9bb _InvokeEventHandlerUPP(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*, long (*)(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*)) + 36
46           	0x97c35394 DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1343
47           	0x97c34780 SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 430
48           	0x97c48655 SendEventToEventTarget + 88
49           	0x97c685f6 ToolboxEventDispatcherHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 2188
50           	0x97c3583f DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 2538
51           	0x97c34780 SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 430
52           	0x97c48655 SendEventToEventTarget + 88
53  net.sourceforge.audacity      	0x003e4056 wxApp::MacHandleOneEvent(void*) + 38
54  net.sourceforge.audacity      	0x003e412f wxApp::MacDoOneEvent() + 127
55  net.sourceforge.audacity      	0x003fca53 wxEventLoop::Dispatch() + 35
56  net.sourceforge.audacity      	0x0048f68f wxEventLoopManual::Run() + 111
57  net.sourceforge.audacity      	0x004698d3 wxAppBase::MainLoop() + 83
58  net.sourceforge.audacity      	0x0054a34a wxEntry(int&, wchar_t**) + 154
59  net.sourceforge.audacity      	0x0003f24b main + 91
60  net.sourceforge.audacity      	0x0003efae _start + 216
61  net.sourceforge.audacity      	0x0003eed5 start + 41

CrashReport.txt (45.5 KB)

It wouldn’t do - audacity.cfg goes in your home Library, that is ~/Library/Application Support/audacity.

OK so you established the Registry Error was coming from am Audio Unit or VST plug-in. You could experiment with the VST plug-ins if you wanted to. Choose Audacity > Preferences, choose “Effects” on the left again, enable all the VST options (including the option to Rescan for VST plug-ins), then restart Audacity. In the “Install VST Effects” dialogue that appears, you can uncheck all the plug-ins except one, then click OK. If there is no error, repeat the steps, enabling an extra plug-in each time until you find the culprit.

Of course it might be an Audio Unit plug-in. If it is, you can try this 2.0.5-alpha test build that should put all the Audio Units in Audacity’s Effect menu, but not load them until you choose them from the menu. So if it worked, you would not get the Registry Error until you chose the errant plug-in from the menu.

However that r12571 build has a bug that affects sound quality of exports, so only use it if needed to debug the Audio Unit that has the Registry Error.

If you find which plug-in caused this Registry Error, please tell us.

Are you saying you still get error opening when setting the Audacity playback device to the mixer? If so, you will probably need to set up the USB codec for the mixer. In Finder, choose Go > Utilities then open “Audio MIDI Setup”. See here Missing features - Audacity Support .

2.0.4 has an import crashing problem so I suggest you use 2.0.3 or 2.0.5-alpha. You can find links to 2.0.3 or 2.0.5 alpha here: . The 2.0.5-alpha in that topic is later than the test build for Audio Unit loading, so it won’t have the export quality issue.



I think it may be Audio Unit AUMatrixReverb. I noticed that it didn’t work in r1257, no error message, looked like it worked but nothing changed. Never got the Registry Error in r1257 either. But in 2.0.4 unchecking Audio Units got rid of the Registry Error.

Only the VST plugins show up in the menu when Audacity scans for them.

My system configuration was slightly off so fixing that fixed the codec problem.

Your help is much appreciated, thanks.


I am not quite clear what happened when you ran r12571. If there was no Registry Error, that suggests that loading was not done when Audacity launched, which is as intended.

Was Matrix Reverb in the Effect Menu, but when you clicked it in the Effect Menu, nothing happened?


Yes, it was in the Effect Menu, when checked in preferences and had Audacity scan for plugins. Never got a registry error with r1257, even with all plugins check for scanning. This was actual working of the plugins on a recording.

First I set it up so that the plugins wouldn’t load, next I loaded them and still not registry error. So I checked the AUs and they all worked except for Matrix Reverb…it came up just like normal, could make adjustments,etc, but did nothing except disappear like it would ordinarily do when you tell it to do it, but it didn’t do anything, didn’t even register in the Undo. Found this out when I hit Cmd-Z to undo and my recording go erased. It acts like it works but doesn’t.

I downloaded 2.0.5 and get the registry error if the “(Load) AudioUnits” is checked. All the other plugins load without a problem. The Matrix Reverb doesn’t work in 2.0.5 either, same action & result as in r1257.

The AUs don’t show up in the menu to select or de-select when you tell Audacity to scan the plugins so I don’t know how to isolate that group to work with them. Did a search but couldn’t find anything matching Matrix Revert, AU, audio units or Apple.

Wish I could be more help.

Thanks for your help Gale.


Thanks for testing.

To be clear, the Effects Preference “Rescan VST Effects” only scans for VST plug-ins. There is no dialogue to choose which Audio Units to load.

The intention of r12571 (if the Effects Preference is set to enable Audio Units) is that there is a scan of Audio Units, but not a load. This should mean that if an Audio Unit effect has a prompt or a warning, you should not see that prompt/warning until you actually choose the effect from the Effect Menu. So that seems to be working correctly from your description.

As I understand it AU Matrix Reverb comes with Macs and is free, so I have no idea why it gives you a registry error. It doesn’t give me that error. Note that Matrix Reverb cannot be used on a mono track .

If Matrix Reverb gives you a registry error, please contact Apple support.


Things make a little more sense now. I was using a mono track and that’s why the plugin didn’t function. Since the Audio Units come with Mac they may be in Garage Band folders. I’ve never used Garage Band or the Audio Units but its good to know this. I certainly have no problem leaving the Audio Unit box unchecked. I’m glad its not a problem with Audacity.

I’ve enjoyed using Audacity since I started my Voice Over business recording audiobooks. I use Reaper to do the initial recording as I save a few keystrokes with Punch & Roll, then edit and master in Audacity. Maybe some day Audacity will get the ability to just place the curser before an already recorded section, hit record, and record over it. It’s amazing that it’s free. I think Audacity is getting a better reputation due to being recognized for the great job it does but there are still folks out there who can’t get their minds around the fact that it can be an excellent program and be free too. They’d rather spend hundreds than even give it a try.

Thanks again for your help Gale,


That’s one of our most popular feature requests, so it sounds as if you would like that too.

In case you don’t know, if you stop recording at the mistake point then you can do SHIFT + R to record from the end of the track. If there are multiple tracks you need to select the track you want to append record to.


True. Doing audiobooks it would really be nice just to place the cursor before the mistake and record over it. It must take quite a bit of programing to get it to do that as this type of function is found mostly in the DAWs like Reaper, ProTools, CubeBase, etc. Eventually it may find it’s way to Audacity…when it does it will be the only program I use.