USB Audio Recording Glitches (2.0.3, Win7)

Hello forum,
I’m using the latest stable Audacity, 2.0.3 (installed from .exe IIRC), on Windows 7 Home Premium 64-bit. I’ve used Audacity for ages with my Artcessories USB phono preamp for ripping vinyl and the occasional cassette. I don’t remember running into problems before on my aging machine running Windows XP, but since I have recently moved to using my somewhat more recent build with Win7, I’m having some kind of recording issue wherein small audio glitches are produced in the audio stream. To be honest, I’m not 100% sure what settings I have been using up till now in Audacity for recording; I tend to tinker a lot and forget what I’ve set. During tonight’s research I’ve learned about the “exclusive mode” settings available in Windows 7. It looks like I had had them checked already on the preamp recording settings pages, or it’s possible they already were (because I don’t remember checking them). However, I think I did not have “Windows Direct Sounds” selected in Audacity for the Host, but MME. Again, I’m just not completely sure about that.

When it comes to the actual recording, on my old machine I typically closed all other applications and as many unnecessary background processes as possible when recording, to eliminate these kind of computer glitches. Upon migrating to using my newer machine (which, for the record, is 3.21 GHz CPU with 4 GB RAM), I did not worry too much about closing all those things and left some nonintrusive programs running. However, once I noticed these artifacts in my recordings, which were certainly not from the source, I tried the same technique I used to use. Unfortunately I’ve found my problem still occurring, although perhaps somewhat less so.

Tonight I’ve set Audacity’s Host to Windows Direct Sound as a step toward eliminating this issue. However, since the problem itself is sometimes hard to identify, and I don’t know how to reproduce it, I thought I’d share my experience here first, and post some examples, to try to get some more feedback as to any further actions I can take before I dive back in to the somewhat lengthy process of reripping albums when I may not have solved my problem.

The first sample is a very obvious glitch at around 5.5 seconds. This is actually from my second rip of the album (OMD’s new one). The first time around the glitches were especially egregious; I actually thought it was the needle mistracking or some other weird turntable thing.
The second sample is much more subtle (I didn’t notice it upon the first few listens), starting around 14 seconds or so.

If I’ve left out some important details (as I’m sure I have) just ask and I will try to provide more info.

moved to using my somewhat more recent build

Yes, but did you change the machine?
Do you have your preamp plugged into wall power, or is it getting its operating voltages from the USB?

We’re talking about the “rough road” patches right? Initially, I thought you were talking about the tics here and there, but those are needle versus cat hair noises.

Are you going through a USB hub?


  1. No no, no changes. This computer is the same as it’s always been except now I have the preamp USB plugged in as well.
  2. I use the USB power as I always have. There was an external power supply I’ve misplaced over the years.
  3. I believe the most obvious example is in the first sample. I wish I hadn’t deleted my initial rip as, like I said, the errors were atrocious and extremely obvious throughout. But it was pretty much more of the same. In the second example I can best describe the artifacts as being “garbled” and can best be heard as “breaks” in the synth patch playing. It is subtle but I can’t exactly “unhear” it now that I’ve noticed it. :wink: I’ve yet to verify it isn’t an issue with the actual LP but I highly doubt it.
  4. No hub, it is straight into the back of the computer.

As far as I can narrow it down, the only known difference between now and my “last good configuration” is my operating system and the machine itself. I want to say I can probably rule out hardware since everything in that department is an all-around upgrade, though I suppose faulty USB connections could possibly be at fault.

It looks like skipping : the computer was not listening for few milliseconds so parts of the waveform are missing joined by almost vertical lines …
glitch1, waveform & spectrogram.gif
Have you tried giving Audacity higher priority in the Windows OS , so it is not interrupted by other processes (like antivirus).

Thank you! I had an inkling that was the sort of thing that was happening, but I did not really know the correct terms for it.
I’m hoping putting some more of those measures into place will solve this problem.
I wrongfully assumed higher computer resources would make the same USB recording task a breeze, forgetting just how much of a resource hog Windows really is.