USB Audio No Recording Level Button or Adjustment

HP EliteBook 6930p
Windows XP SP3
SoundMAX Integrated HD Audio driver
Audacity 2.1.0 (installed directly from Audacity website)
Mackie PROFX12

I’ve researched the web and found some folks having this problem, but no real solutions posted.

We’ve been using Audacity for years to record using the tape out of the Mackie mixing board fed into the line-in jack of a desktop computer. (We use the Mackie USB jack to feed music from the desktop line-out back into the mixer.) Recently we have tried to upgrade the desktop to the HP laptop. The laptop obviously has no line-in so we are using the Mackie USB port to feed the laptop. I first noticed that the recording slider on Audacity works (is not grayed out and will slide) but it has no effect on the level. Bringing up the audio controls on the laptop i noticed that the volume button under Sound Recording for the USB Audio Codec is grayed out - no level adjustment. I made sure that the laptop has the latest SoundMAX driver, and the volume button under Sound Recording is there for the SoundMAX codec. Just for grins I also tried a Behringer UCA202 USB audio adapter, but got the same result (no volume button under Sound Recording). I tried uninstalling the SoundMAX driver and adding the USB in case perhaps the SoundMAX was overriding the USB audio and not allowing the USB to make adjustments, but no luck there either. There is no output level adjustment on the Mackie mixer and the default recording level is not enough to produce a decent recording.

Any help would be much appreciated!

This just screams you’re running the mixer wrong. Where are the sound meters on the right of the mixer? I would be running them at the “0” point. If you have a pleasant mix, adjust the Main Fader (lower right) until the meters bounce in the right place. If you can’t get there, then you did the mix wrong, etc. etc.

You can do all this without Audacity or the computer or even listening to it. After the mixer is happy, then connect the computer and Audacity.


There is a suspicious knob called “USB Thru.” What does that do? I’m very leery of people having troubles with very complicated mixers.

“Turns out we had ‘Cathedral Effects’ in the line and it was knocking the level down.”


SoundMAX is motherboard audio, nothing to do with USB audio.

Also please see Important information for Windows XP users about the security risks of running XP now that Microsoft do not support it.

Another issue may be that a new HP laptop would not come with Windows XP. Have you installed XP over the Windows 7 or 8 that comes with the laptop? Is this what you are trying to adjust -

If you have 64-bit Windows XP your mixer does not support that.

Are you selecting the correct recording device in Audacity’s Device Toolbar?


and the default recording level is not enough to produce a decent recording.

What are your peak levels?*

The “good news” is that adjusting the level after recording (with Audacity’s Amplify effect) is no different from digitally adjusting the volume as you record.

Peaks of -3 to -6dB are ideal depending on how predictable your levels are. But, I wouldn’t worry unless you are below -12dB. Pros often record at -18dB, but they are using low-noise 24-bit analog-to-digital converters so they can still get a good signal-to-noise ratio.

There is no output level adjustment on the Mackie mixer

I assume the master volume control affects the analog output and the USB?

They may have left some headroom so the digital signal doesn’t clip when you hit 0dB on the mixer’s meters. That would make sense, because in a “live” mixer situation you never know when an unexpected peak is going to come-along. There will be some headroom in the analog circuitry and you wouldn’t want that unexpected peak to clip the digital output. (The PA amplifier may clip if it doesn’t have headroom, but that’s another issue.)

Or, 0dB on the meters may correspond to 0dBFS (digital). …I assume the mixer has meters or some kind of level/clipping indicators.


  • You can quickly check the peaks by running the Amplify effect. The Amplify scans your file to find the peak, and then it defaults to whatever gain is need for 0dB peaks. i.e. If Amplify defaults to +6dB, your file currently peaks at -6dB.

Thanks all for the feedback. As i mention in my original post we’ve been using this exact setup for years with the desktop with absolutely no problem, so it’s hard to believe it’s the mixer board or set up. The laptop is not new and originally had XP installed. What I was really hoping was that someone could tell me why the recording level button for the USB Audio Codec is missing in Windows and how to get it back. It should be there. If I just can’t get it back then I’ll move on to the mixing board and what can be done there, though again I don’t think the level of the tape out/USB out can be adjusted. Also I understand the effects (like Amplify) have to be applied after recording. Assuming so I’d rather not have that extra step in the process (though I understand it’s not a huge deal.)

I don’t want to shut down any further posts, I just want to encourage anyone who knows how to get that button back (and the ability to adjust the recording level on Audacity) to come forward!!

Is it 64-bit XP? Then your mixer does not support that version of XP.

What have Mackie told you about the problem so far? Is the “Advanced” button also greyed out when you select the Mackie USB CODEC under Sound Recording in Sounds and Audio Devices?

What information does Start > Run, type


and click OK give you about the Mackie?


32 bit (XP Home Edition)

I have not contacted Mackie as of yet. It seems to me like a Windows problem rather than a Audacity or Mackie problem, but one that someone from the Audacity or Mackie community may be familiar with. I chose the Audacity community first and will contact Mackie if I don’t have any luck here.

There is no “Mackie” USB CODEC, only the generic USB Audio CODEC (and of course the native SoundMAX HD Audio). On the USB Audio CODEC both the Volume and Advanced buttons are grayed out. (On the SoundMAX the Volume button is there but the Advance button is grayed out.

I’m not familar with the “CODE: SELECT ALL” command. I tried putting it into the Run command but it didn’t seem to recognize it. I put in the dxdiag, which I assume is what you wanted me to Run, and got the output below for the USB Audio CODEC. The data does not mean anything to me. I did the Test DirectSound and it passed.

Further thoughts?

Mackie makes the mixer and claims support for XP. It is also down to them to tell you how to adjust the output level of the mixer over USB.

The only other suggestion I might have is to look in Windows Device Manager while the mixer is connected. Look under “Sound, video and game controllers” and “Universal Serial Bus controllers” for any yellow exclamation marks which could indicate a problem. Right-click over the USB audio codec assuming you see it under “Sound, video and game controllers”, choose Properties then the “Driver” tab. You can investigate any options there may be to update or roll back the driver.