USB Audio CODEC doesn't show up in Sound Preferences[SOLVED]

I have a Stanton T.90 and am operating a Mac with OS 10.6.8. I plugged the USB into my computer, turned on the turntable, opened Audacity and did the scan for devices. Still no USB Audio CODEC under the options for input or output. I plugged it into another Mac laptop, and I still do not see USB Audio CODEC as an option in the Sound Preferences. How do I get it to show up?

You don’t if it’s broken. Did it ever work? Try another USB cable and fit it tightly both ends.

If your Mac has a line in, buy a stereo 1/8 inch TRS to TRS cable, and connect it between line out of the T90 and line-in of the Mac. Set the Phono/Line switch on the turntable to Line. Set Audacity to record from line in.

Return the turntable if the line out does not work either.


That’s the circle and two black arrows.

Close Audacity.
Apple (upper left) > System Preferences > Hardware > Sound > Input. The sound device has to show up there before Audacity can get to it.


We bought this record player 7 years ago and just opened the box and plugged it in last week. So I never thought that the brand new firewire to USB cord could be the problem but I changed it out with another and it works! Thanks for the tips! Now moving on to playback and recording…