I just got an audio technica usb turntable and audacity came as the software to be installed on my macbook pro.
Upon opening the program once installed, Izotope Trash opens up automatically, prompting me to register the product (izotope trash, not audacity).
I have tried everything to get rid of the Izotope Trash plugin or program or whatever the f* it is to no avail. I have removed it from apps, removed it from trash, have reinstalled audacity twice, and still it attempts to open izotope trash upon opening audacity.
Also the signal from the usb is being recognized in my input, but will not playback out through speakers connected through headphone jack.
This is really annoying.
Please share any advice.
Thank you.

Unless you got Audacity from us, you may have gotten a highly customized software package.

Drag Audacity from Applications to the trash.

Desktop > Go > /Users/koz/Library/Application Support (Obviously, you need to be you and not “koz”.)
Drag the “audacity” folder to the trash.


Download and double click on the .dmg file and it will explode into the program folder and an instructional text file. Drag the program folder into /Applications.


Audacity > Preferences > Devices > Recording and Playback. Set those to where you want the sound to come from and go. Audacity recognizes USB devices already connected when it starts.


Then it almost certainly won’t be the latest Audacity 2.0.5, as Koz says. Making sure you have the latest version of Audacity is top recommendation in our Tutorial - Recording with USB turntables or USB cassette decks .

Izotope Trash is nothing to do with Audacity. If the Izotope plug-in is an Audio Unit plug-in then 2.0.5 won’t try to load it when it starts up, so you should not see the Izotope nag message.

You can open Finder then Go > Go to Folder and type either of these locations to find offending Audio Unit plug-ins:




This new version solved the problem.

OK. Note that I expect the Izotope plug-in will still be in the Effect Menu and it will nag if you try to use it. The only answer to that is to remove it as described (or pay for it).