Upgraded to 2.1.2 and can't import from iTunes

Good evening all, as above I have recently upgraded to 2.1.2 having used an older version for several years. The older version had recently crashed and lost a radio show I had compiled so decided to upgrade. However, I have found that I cannot just import music from iTunes as done previously by clicking and dragging onto a new project. Have I somehow not adjusted the settings to allow this to happen?. I have looked at the tutorials which say to drag across and drop but it does not elaborate on any part if this does not happen!. I run 10.11.6 OS X and set up using .dmg installer. Many thanks, Bryan.

I don’t do it quite that way. I drag an iTunes show onto the desktop where it settles in to a stand-alone sound file.

Then I open it in Audacity. Right-Click or Control-Click on the file > Open With > Audacity.

If you do that, which part fails?


Thanks for that. I have just tried to do what you suggest but it opens in a different project which I then have to cut and paste onto the existing project. I used to be able to just click and drag the tune across. Now when I click and drag the tune it has the green cross but I can’t attach it to the new project.

If you look in the 2.1.2 Release Notes you can see a little way down that it’s a bug in 2.1.2:

Audio files cannot be dragged into the Audacity window. You can drag files to the Audacity icon in /Applications or in the Dock, or import the file from within Audacity.

Drag to the icon will open a new project window, so use File > Import > Audio… from within Audacity.

It will be fixed in the next 2.1.3 release of Audacity.


Thanks Gale, that will teach me not to read the notes thoroughly!. I await the update with baited breath…