upgrade heck

I just upgraded my Audacity 1.3(beta) to 2.0.1 and had a problem. I tried to open an Audacity 1.3b project with ver. 2 and it wasn’t entirely successful. Audacity 2 believed there was an open project, the timeline seemed to reflect the correct size of the project but there was no track window (the 1.3 project was about 7hrs, mono, 22khz).

I understand Audacity 2.x somehow won’t work with earlier Audacity files, is this the kind of behavior I would see as a result of this incompatibility? If not, then what am I seeing?

At this point, can I successfully save the 1.3 project as a 2.0 project by just doing a “Save As…”?

Is there a tool or method for converting older Audacity projects (1.2 and 1.3) into 2.0 projects?

Say I don’t have the version of Audacity that created the project, I only have Audacity 2, are those older projects lost?


If there is a problem, DO NOT use “Save” to save the project - it will overwrite the original.
(more to follow…

Was there an error or warning message?

To safely attempt to open a project, make a copy of both the .AUP file and the project _data folder. Don’t change their names, just make a copy inside another folder. Then try opening the copy. Do you get any error messages or warnings? If so, what exactly do they say?

Audacity 2.0 should be fully compatible with previous versions except that some previous versions may have produced damaged (faulty) projects. Audacity projects are a lot more complex than a simple audio file, so things can go wrong with them, particularly projects from older versions of Audacity.

Yes you can use “Save As” to convert an older version project to an Audacity 2.x project. Actually an Audacity 2.x project is basically the same as an Audacity 1.3.x project, so there is no real “conversion”. Audacity 1.2.x projects are a bit different and after being saved by Audacity 2.0 they will no longer be compatible with Audacity 1.2.x.

Well, that was weird. I tried opening a couple of other older Audacity projects with 2.0 and those looked okay. These older projects were created with a Mac PPC version of Audacity (1.2 maybe). The one that messed up earlier today was created with 1.3b on Windows. Maybe the problem was with 1.3b. In any case, for now, I guess I don’t see a problem.