Updated to 2.0.5 and Audacity won't record

Updated to 2.0.5 and now Audacity doesn’t pick anything up during record. Just a flat line. Windows 7 pro, i7 processor. Audio host = MME; Output = Realtek speakers; Recording device = Stereo Mix (realtek high definition).

Please see here: http://manual.audacityteam.org/o/man/tutorial_recording_computer_playback_on_windows.html .

Note that you have to turn up the volume of the audio you are playing in order to record from stereo mix.

If Stereo Mix does not work, use Windows WASAPI host and the loopback input instead (see the above link for explanation).


@Gale. I’ve gone through the suggested web page twice. When trying Wasap setting, I get an error msg: Error while opening sound device. Please check the input device settings and the project sample rate. I checked that Stereo Mix and my sound card are enabled. Sample rate is 44.1khz

Change to Windows DirectSound host in Audacity.

Right-click over the speaker icon by the system clock, then choose “Playback Devices”. Right-click over the Realtek speakers then choose “Properties”. Then click the “Advanced” tab. Make sure “Default Format” is 16-bit 44100 Hz. Try it with both “Exclusive Mode” boxes checked. Restart Audacity, Project Rate 44100 Hz.

If it still errors, try it with both “Exclusive Mode” boxes unchecked.

Make sure the Realtek drivers are the latest Windows 7 drivers supplied by the motherboard or computer manufacturer. Please see http://wiki.audacityteam.org/wiki/Updating_Sound_Device_Drivers .


No change. I’m thinking about uninstalling and going back to the previous version.

Did you try any more of the suggestions, especially ensuring the drivers were correct?

Which previous version did you have? I don’t think anyone else has found that stereo mix stops working in 2.0.5, but should there be a problem with the audio drivers, anything can happen.


I checked my drivers and I saw both 64 and 32 listed. I tried Windows Direct. For input device I tried both Stereo Mix and Primary Sound Capture. Also, I tried the options under Output Device. None of the combinations worked. The previous version I had was just before 2.0.5 as this computer was built in January.

I have tried each of the suggestions, at least once.

I thought there might be a relation to the 7.1 speaker system hooked up and my RealTek audio settings. I changed my RealTek audio settings to various settings (7.1, 5.1, stereo, etc), but that had no effect.

My motherboard is: ASUS P8Z77-V LK LGA 1155 Intel Z77 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard with UEFI BIOS. The sound card is: Realtek ALC892.

BTW. I appreciete your help so far. Thanks.

Is this a 64-bit processor? If you right-click over Computer > Properties, does it say 64-bit?

What is the make and model number of the computer? If it’s a branded computer like Dell or HP, you should check the manufacturer’s web site for the latest drivers for your computer model and Windows 7 (32-bit or 64-bit as appropriate).


This is a 64 bit system. Custom designed computer for gaming/video editing.

The motherboard is ASUS P8Z77-V LK.

For Sound, video and game controllers I have:
Audials sound capturing = driver is RapidSolution Software, 10/9/2012, version 6.0.4000.0 (system 32 drivers)
NVIDIA high def audio = driver is NVIDIA Corporation, 6/16/2013, version (system 32 drivers)
NVIDIA virtual audio device (wave extensible)(WDM) = driver is NVIDIA, 10/31/2013, version (system 32 and 64 drivers)
Realtek high definition audio = Realtek Semiconductor Corp., 6/12/2012, version (system 64 drivers) This is the current driver listed on Asus’s web page for this motherboard: http://www.asus.com/Motherboards/P8Z77V_LK/#support (Realtek Audio Driver V5.10.0.6657 for Windows XP 32bit & XP 64bit—(WHQL). Realtek Audio Driver V6.0.1.6657 for Windows Win7 32bit & Win7 64bit & Win8 32bit & Win8 64bit—(WHQL).)

Maybe there is some conflict between the multiple audio devices you have. I believe “Audials” will show as multiple virtual devices in Windows “Sound”, is that correct? Does Intel show as a separate device in “Sound”? I would guess not.

Can’t you record computer playback with “Audials”? What happens if you disable “Audials”?

The PortAudio audio interface we use for playback and recording was updated for both Audacity 2.0.4 and 2.0.5. So you could go back to 2.0.3 or 2.0.4 and tell us which version records for you, if any:
http://audacity.googlecode.com/files/audacity-win-2.0.4.zip .

Make sure you quit 2.0.5 before running another version.

However you could simply have something configured incorrectly that we can’t see. Can you ask the person who built your computer, or was that you?


I uninstalled 2.0.5 and tried 2.0.3. No luck. Then tried 2.0.4. No luck. Reinstalled 2.0.5. No luck. I just can’t figure out what’s going on or what has changed.

Virtual audio devices like “audials” are going to make things more complicated. Do you use it for recording movie audio? Did you install audials just before the problem started? Can you disable its audio devices but still use its movie search or whatever it does?

What else did you change before the problem started?

Do you have a system restore point you can go back to just before the problem started?


Audials was installed with Nero 12 back in February. I rarely use Nero. I have used Audacity successfully after installing Nero. I disabled all Audials in my ‘playback devices’ as suggested. No luck. Maybe I should check my Audials settings.

And for some reason, there are 28 instances of Audials Sound Capturing showing up in Playback Devices. All are disabled.

It’s obviously not an Audacity problem.

Another obvious point to make is that whatever you are trying to record must be playing on the Realtek device. You can’t play it on a USB headset then record it on Realtek stereo mix because the USB headset is a different device.