Unwanted Click On Short Over Dubs


Audacity 2.1.1 used zip.
Windows 8.1 Inspiron Laptop 8 core machine - I cant tell you offhand memory and disk but it is a pretty powerful machine and I dont have a lot on it.
I do not run over processes when recording.

I am new to Audacity and so far its fantastic apart from one minor problem that crops up very regularly.

I am overdubbing short alto sax riffs onto a backing track.
Simple set up so latency is present - sax microphone with XLR output into microphone preamp and then into laptop via stereo Jack, headphones used. The latency
is not bothering me but it could be associated with the problem so I mention it.

Each “take” is typically only 10 seconds long but some are a minute or so.

On at least 60% perhaps more I get a single “click” a second or two into the take, the click appears on the dB waveform as a single thin vertical line which is a at least factor of 4 greater amplitude than the surrounding waveform, I say at least because it fills the entire vertical height of the waveform window.

I do not believe it is simple clipping as I understand it for the following reasons.

  1. I don’t recall getting two or more clicks in one take, I think it has always been one.
  2. It does not seem to be related to the volume at which I am playing, for instance if I play quietly then loud the click is often in the quiet part.
  3. It is always a second or so into the take, never in the middle or the end, I can replay the take and the click will usually be in pretty much the same place.
  4. When I do a longer take I still get one click near the start.

The click is never for a long duration, it is a clean vertical line in the waveform with very little width, either side the waveform looks normal.
The audio effect is like a bad edit, a kind of discontinuity in the sound, I described it as a click but really its more like a bad edit with a disruption to the sound, another approximation would be a very quick disturbance to a sound due to a loose speaker connection. I do not believe it is a connection problem because it always happens 1 second or so into the take.

I experience the same problem when I record with my laptop’s inbuilt microphone.

I cant help thinking these symptoms suggest a software or hardware issue, like say a buffer filling and something happening as a response that causes
a momentary disruption.

Kind regards

Laptops are not professional recording studios. Unless you have two audio inputs, mic and line, then the input you are using is not a proper line-in for already-amplified signals. The noise could possibly be avoided with a USB interface where the sound device is not inside the computer.

Could you post an audio sample of the click?

You might be able to use Process Monitor to see whether some process appears then disappears near the start of a recording.

Are the drivers of the built-in sound device up to date with the latest drivers obtained from the Dell web site? If not, try that.


Hi Gale

Thanks for the quick response.

Update: When you plug in a microphone or headphones into my laptop it asks you what you have just plugged in, there two jacks one for headphones and one for microphone but it asks you every time regardless.

I tried this time answering “line-in” for my microphone on the basis that it has a pre-amp, previously I had answered microphone.

Now I get a very low volume recording even when I set recording levels and playback levels to top position so I suspect that my microphone preamp does not
deliver line-in levels, it delivers XLR output which I am then converting to mini-jack with a suitable lead.

Anyway the waveform is tiny but when I listen there are no clicks and the quality does sound better but this could possibly be something to do with having such a tiny signal as I believe the effect of that at a digital level will be not unlike compression.

I do get the clicks with the laptop’s own microphone and also a cheap condenser mike but you have given me food for thought and more variables to play around with. I will look into the USB options.

I am not out of the woods yet but a bit further thanks to your useful suggestions - thanks.

If I do work it out I will of course post so that others might benefit.

OK, then in that case perhaps it only provides phantom power and/or minimal amplification because it is intended for connecting to mic ports.

A mic input on a USB mixer or USB interface would provide line-level amplification.

The signal is too low because I assumed the pre-amp delivered line-level. However you could use Effect > Amplify… in Audacity to hear whether there is a click.


Hi Gale

I think I have it now.
The software that controls my soundcard is called “Dell Audio”
I experimented with LEVELS >> External Microphone.
It is odd, there is a slider to set level but on top of that there is a feature to add a Microphone Boost of
0, 10, 20dB and so on.
It was defaulted at 20dB I set it to zero.
Not sure what the boost is, cant be across the board as then whats the point of the slider, must be a bass
or treble boost.
Either way turning it down to zero removes the problem.
Thinking about it - it might have been a treble boost as my first riff does have a sustained high note
in the place.
I am now running XLR microphone with outboard pre-amp into microphone jack and its sounding great.
Thanks for your advice, it gave me a feel for what I should look at.

KInd regards

Thanks for letting us know what fixed it. I have not heard before of boost creating a once-only click near the start of a recording. The boost is not equalization. It’s a boost before the slider level takes effect, and the boost should be evident as soon as you start recording.

If boost doesn’t kick in at once or creates a click I would call it a bug in the audio drivers. You should check at Dell’s site that you have the correct drivers or you may receive weird or intermittent problems.