Unrestricted Audacity 2.0.4 is working fine on Windows 8

It seems a lot of people have trouble running Audacity 2.0.4. This is just to say that it is working fine on my Windows 8 64 bit system with integrated RealTek High Definition Audio. Both the Direct Sound and WASAPI drivers are recognized and allow me to record streaming radio without any glitch.

Thanks, Robert2.

If you want to try, can you play and record if you choose the Windows WDM-KS host instead of DirectSound or WASAPI? Some people have said WDM-KS does not show all the inputs that the other hosts show.


I just chose WDM-KS. I recorded streaming radio from http://www.sky.fm/play/classical, and exported it as FLAC, which played fine in Foobar2000.

—Now if I choose MME, I get 3 playback options:

a. MS Sound Mapping output
b. Speakers (Realtek High Def)
c. Realtek Digital Output

And 2 recording options:

a. MS Sound Mapping input
b. Stereo Mix (Realtek High Def)

—If I choose Windows DirectSound, I get 3 playback options:

a. Default audio output
b. Speakers (Realtek High Def)
c. Realtek Digital Output

And 2 recording options:

a. Default audio input
b. Stereo Mix (Realtek High Def)

—If I choose Windows WASAPI, I get 2 playback options:

a. Speakers (Realtek High Def)
b. Realtek Digital Output

And 2 recording options:

a. Speakers (Realtek High Def) (loopback)
b. Realtek Digital Output (Realtek High Def) (loopback)

—If I choose Windows WDM-KS, I get 2 playback options:

a. Speakers (Realtek HD Audio output)
b. SPDIF out (Realtek HDA SPDIF out)

And 2 recording options:

a. Stereo Mix (Realtek HD Audio Stereo input)
b. Line in (Realtek HD Audio Line in)

@Gale, a question. The Audacity manual includes these lines:

“Under WDM-KS, only one application is allowed to access the audio device at a time. So for example if you are already playing audio in the web browser or another application, you will not be able to play audio in Audacity using the same device that the other application is using.”

I don’t understand this. If I am already playing audio in the web browser to the speakers, of course I cannot expect another sound from Audacity to be output to the speakers concurrently. How is this special to WDM-KS?

It presumably can’t play previously recorded sounds along with the sound in the web browser.
This overdubbing works with WDS.
I can’t test it myself, the playback with Wdm-ks does not yet work on my system.
I succeeded twice to play a sound after calling properties in the control panel and pressing ok. After going back to Audacity, the sound played. A temporary change of the host caused anew a device error though.
I have a ATI HD rear output and a sound blaster. The ATI output is deactivated in the Windows device manager. It seems that this output would play normally if I used it, but I can’t always switch the speaker cable.
It is nice that you’re system works properly.

@Robert2: Thanks for listing your inputs and outputs. You could make a list with less effort if you open Help > Audio Device Info…, right-click > Select All and copy.

The inputs and outputs look good, except I am puzzled that only WDM-KS sees the line-in. Is that a real input that you have enabled in Windows, or a spurious item?

It’s special because MME, Windows DirectSound (if “Exclusive Mode” is unchecked for the playback device in Windows) and WASAPI (similarly if “Exclusive Mode” is unchecked) explicitly allow different applications’ audio playback streams to be mixed together. WDM-KS does not allow mixing of streams from different applications because Windows always regards WDM-KS as “exclusive”.

But WDM-KS does allow multiple different audio devices to be mixed (as long as only one application is using each of those devices).


Nothing spurious about it. I have digitized hundreds of cassettes with a cable connecting the line-out from a Marantz tape deck to my motherboard line-in, —and Audacity of course (version 2.0.3). Worked beautifully!

OK, but you should also be able to record from line-in using MME or WDS. There is something wrong if you cannot. Line-in should be listed separately under MME and WDS even if line-in is the current Windows default.


Line-in is listed under MME and WDS only if the hardware cable is actually plugged into the motherboard back panel. This does not seem necessary with WDM-KS.

Thanks for the explanation.

So if you choose line-in with WDM-KS host when line-in is not connected, then record, do you record silence, or does it give “error opening”?


This is a first. I never tried recording silence before. :unamused:

When I unplugged the line, I got a message from the Realtek systray applet saying that the line-in connection was lost, but when I recorded through WDM-KS and the line-in “device”, Audacity dutifully recorded silence. I was able to export the file as FLAC without any problem. I wonder if this would sell? It is the most perfect silence I ever heard… :sunglasses:

My external mic is listed in Audacity and records “silence” under MME, WDS and WDM-KS when not connected (as long as it’s “enabled”). This varies from device to device but it’s interesting that WDM-KS is different for you from the other hosts.

But thanks for the test and information.