Unpredictable tech clicks in sound file

I am using the latest Audacity, 2.1.2, downloaded yesterday onto my new Mac mini OS 10.11, El Capitan. I downloaded and installed Audacity via the dmg.
Today, I was recording, and was experimenting with ‘punch and roll’ style editing. When I made a mistake, I deleted the section with the error, then did append record so I could pick up where I left off. Seemed great. Then there started to be weird technology clicks, but only SOMETIMES. In other words, I could delete then append record and sometimes that went great, and other times it was chock full of weird techno clicks.
Any advice you could give me would be greatly appreciated!

The first thing that comes to my mind, is: “is your OSX up-to-date?”

10.11.5 had weird USB problems for some. 10.11.6 has fixed that for most.

Thank you! I believe so. I set it up two days ago and approved an upgrade at that time. I will double check, though.

Look under the Apple menu, “about this Mac”. There you can find the system version installed.

Here is what I can say; it is OS 10.11.6. I have 8 gb of RAM, not 4, so that is plenty. I am running El Capitan. No cords are touching any other cords, and all connections have been rechecked for snugly fittingness (which I hereby declare to be a word). Also, it pops up randomly, in the middle of recording, and may or may not disappear with stopping and starting again, and is not contingent upon whether I stop and record or stop and append record or just pause. It has been suggested that I check the settings to be sure the interface …in this case a presonus… Is selected as the primary audio reference.

What exactly do you mean by “tech” clicks? Could you post an audio sample?

This FAQ in the Manual for the next release of Audacity might help:
http://alphamanual.audacityteam.org/man/FAQ:Recording_-_Troubleshooting#mac_crackle .

Don’t use that Manual otherwise, because it won’t relate to the version of Audacity you are using.

What is the model number of the Presonus? Do you need to download El Capitan drivers or firmware from Presonus?


Thanks so much for your help, both of you! The clicks sound “electrical” to me. Although my transformer in the power cord for the monitor was not touching the cable from the PreSonus to the Mac Mini, I thought it might be causing the problem, so this morning I tucked the Presonus/mac cord into a groove in superdense packing foam and also moved the monitor power cable to an outlet on the other side of the room (so now the trans former is 4-6 feet away from the PreSonus/Mac cable). I also unplugged and replugged everything, just in case, and the PreSonus/Mac cable is also not touching the HDMI cable.

A couple other things that I hope will help in determining the cause:
*when I am recording, I can hear my own mouth clicks, even the small ones, in my headphones, but I cannot hear these “tech clicks”. I catch them happening only when I see them in the sound file as I am recording. They look large, almost the size of “K” “T” or “D” sound.
*when I erase mistakes and begin recording again, sometimes everything is fine and then, for no apparent reason, it starts doing it.

I had not thought of needing an updated driver–my PreSonus is a Limited Edition Audiobox USB, made in 2013, listing a need for OS 10.6.8 or higher. I will head back into the studio and check online from there this evening.
I am made two samples, but for space purposes, am only loading one–thank you again for your help!

Hmmm I don’t see the reply I made earlier today, so I will quick recap plus update:
First off, thank you a thousand times for your help and advice!

I checked with PreSonus–I am running a 2013 Limited Edition Audiobox USB, which only has clicky problems with OS10.11.4 and .5, but fixed with .6, and there isn’t a driver I need to update.

I made two samples, and am posting one here.Please let me know if you want the other one as well. This was before I went into the MIDI and tried to align the bit rate with Audacity.
After this sample, I did open/Applications/Utility/MIDI set up Input tab, and saw that indeed my PreSonus is the default sound device, as I had set, and that it was set to 48000 Hz, whereas the default on Audacity was 44100, so I changed it to 44100. It also said “24 bit integer” without an option to change, and Audacity is “32 bit Float” without an option to change that I could see.

It was still a nightmare of unpredictable onset of clickiness, possibly worse. So I fought through it (had to in order to finish a due chapter, which meant just erasing a re-trying until i could get it to not click for a short burst).
Then I went back into the MIDI set up, changed it to 48000 and changed Audacity to 48000… and SO much better! Not sure if it was luck or a short test so the clickiness did not have a chance to begin…but if you have thoughts or advice based on this information, I would be extremely grateful.

Thank you again so very much

The delay in your posts appearing is because your posts are moderated until you become an established user.

Usually it is matching the sample rate (Hz) that matters, not the bit depth. If you want to experiment with 24-bit depth in Audacity, it’s at Audacity > Preferences…, Quality section, Default Sample Rate.


Thank you, Gale, I will try the preferences adjustment to 24.
I am sorry I forgot about the delay.
changing both to 44100 did not improve the situation, possibly made it worse.
Changing both to 48000 reduced the frequency of the occurence, but that still means it happens every couple of minutes.

What could be happening?

Are you sure you followed every single step here http://alphamanual.audacityteam.org/man/FAQ:Recording_-_Troubleshooting#mac_crackle ?

If none of that helps, try recording in GarageBand or some other app and see what happens. If you still receive clicks, ask Presonus about the problem. Perhaps they did not fix the problems they had in previous El Capitan after all.


Thank you so much! i will try Garage Band, and I do have an inquiry in to PreSonus.
You have been amazing–thank you so very very much.