Unicode Export Problem


I just got a new computer and installed a fresh install of Audacity 2.0.5, and the downloaded and installed the Lame DLL from the recommended website via the ‘download now’ button. The following problem that I am describing did not happen on my previous installation, though I do not know exactly what version I had installed. I am running Windows 7 Professional.

I am recording sentences in Arabic that I then export into individual files for my students. I use labels and then “export multiple” to export these files. I fill in the metadata (in Roman characters exclusively) through the Edit Metadata function. I then use ‘export multiple’ set to export MP3 files. It asks me for the metadata for each file, I click through that, but then it throw the following error: “The specified file could not be converted due to unicode character use.” It then pops up a dialog box asking me to rename it. If I hit ‘cancel’ I then get a lengthy error dialog in Japanese (which I cannot read) which I also click through. It moves to the next file and the process repeats. At the end, the files do appear to have been exported correctly, including unicode file names and metadata.

This is a problem I can live with, but would prefer not to have happen. Each time I do this, I export some 20-30 files, so clicking through that ‘error’ dialog is a PITA. I didn’t have this problem on my previous computer.

Thanks for your assistance.

Whatever other characters are in the labels, the following characters are Windows-illegal and will cause Audacity to ask you to replace the characters:

  /  :  *  ?  "  <  >  |

Please look in Edit > Preferences: Interface and tell us what language Audacity is running in.

Then can you please File > Export Labels… and attach the file. Please see here for how to attach files: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1 .

On Windows 7 x64 with Audacity running in English and Windows in English(US), adding metadata or not, I don’t seem to have any problem with this error.


Hi Gale!
Please try to export to some unicode filename, like “б.mp3” (without quotes, it’s the second letter in russian). I’ve got the same popup as skander.

I did, using standard export and Export Multiple, on Windows 8.1 (using the on-screen keyboard).

You need to use Audacity 2.0.5 from Audacity ® | Downloads . Don’t use old ANSI versions of Audacity unless you are on Windows 98/ME.

Don’t add dots into file names.

There is nothing we can do without some information to go. What version of Windows?

What language is Windows is running in?

What language is Audacity running in?

How are you inputting the characters?

Are you using Export Multiple, if so by Labels or Tracks?