Undo function is not undoing correctly

Hello.

I am using version 2.0.5 and i’m running it on Windows 7.

I’ll have to explain what is happening step by step, but the nutshell of it is - the undo is not fully undoing recorded takes.

  • i’ll record a vocal take for a song. When i don’t like how the take turns out i UNDO and record a new one. I have been doing this method for years.
  • Today i recorded a take that i didn’t like so i hit UNDO.
  • Audacity did not remove the entire vocal take. Instead, for some unknown reason it removed a portion of the take and left the rest
  • I thought this was odd so i pressed ctrl-z a second time and it removed the rest of the take but then also it undone the step previous to me pressing record (which was me adjusting the volume of the song i was recording to).

I have never had this problem before. In all honesty i have never had an issue with Audacity before, this is the first time in something like 8 years where Audacity is malfunctioning to the point where i can not work productively.

Please, if this sounds at all familiar and if you know any way in which i can fix this issue then i will really appreciate it.
I have so much work to do and this issue is causing me a lot of problems.

It’s not familiar.

So are the steps these? Are you using the Undo button?

1 Transport > Overdub on.
2 Record a track.
3 Select part of it.
4 Increase the gain on the track using the -…+ gain slider.
5 Record, which records in that selection to a new track then stops.
6 Undo.

I just get the track recorded at step 5 removed when I undo (using our latest code or 2.0.5). I get the same if I do step 4 before step 3.

What happens when you undo? Does it do Trim, leaving only the selection? Are you sure you are not pressing the Trim button?

If you are using a shortcut to Undo, the shortcuts could be corrupted. Try Edit > Preferences, choose Keyboard, press “Defaults” and OK.

Or try reinstalling Audacity with Reset Preferences checked (ticked):
http://manual.audacityteam.org/o/man/faq_installation_and_plug_ins.html#reset .


Gale

I’ve not come across it either.
Does it only happen with one particular Audacity project?

I do use the shortcut Ctrl-Z to Undo so it’s definitely not me accidentally trimming anything.

I’ve also uninstalled and reinstalled Audacity with Reset Preferences ticked and i’m still having the same issue.

This is also happening in every project i’m working in, not just one particular project.

Actually, would it be possible for me to show you some video footage of what i’m experiencing?
Am i able to attach video files to posts here in this forum?
If so then it might be easier to show you guys exactly what is happening.

I’ve searched online all day today and i’ve not found anybody who’s ever had this problem. It’s really concerning me.

The easiest way to post a video is to upload it to YouTube (or similar) and then post a link.

OK, that would also default your keyboard shortcuts.

MOV and MP4 are accepted as extensions, but a video MIME type might still disallow them.

If you used the Windows Problem Steps Recorder it would package a slideshow in a zip. That would be attachable here if it was under the 1 MB limit.

Or post the video to YouTube or Dropbox.

You could work round this by pressing on the track you want to delete. Or select the track you just recorded (DOWN arrow then ENTER) and Tracks > Remove Tracks. You can set a shortcut for Remove Tracks in the Keyboard Preferences (Tracks category).


Gale

Ok, i’ve recorded a short video detailing what’s occurring and how.

You can download it from the following link:
https://app.box.com/s/6u8p18tucz9fk7k33u9t

  • New project
  • load instrumental
  • record vocal take
  • go to undo vocal take
  • undo malfunctions

See if you can make any sense of this, because it’s baffling me :confused:

Thanks for the video. I tried importing a three minute file, clicking in the track two-thirds along then recording, but I can’t reproduce this problem.

Have you quit Audacity and rebooted?

Have you looked in Audacity > Preferences: Directories to find the Audacity temporary directory and checked that there are no AU files in that directory when you launch Audacity?

Or are you saving a project at any stage? If so, where are you saving to?

Have you looked in UsersAppDataRoamingAudacityAutoSave and checked there is only a single AUTOSAVE file there for each project window you have open? You may have to show hidden files and folders to see AppData. See: http://www.bleepingcomputer.com/tutorials/how-to-see-hidden-files-in-windows/#win7 .

The only other suggestion I have is right-click over audacity.exe, choose “Properties”. Click the “Compatibility” tab. Change the Compatiblity mode, for example if it is unchecked, try setting it for current or last previous version of Windows.


Gale

I’ve quit Audacity and rebooted. Turned the entire computer off and on again, just to be on the safe side. Same problem.

I checked the Roaming directory and there was one single Autosave file for each project window i had opened, so nothing unusual there.

I ran Audacity in different compatibility modes and still the same issue occurred.

I checked if there were any AU files in the temporary directory prior to loading a project and it was empty, so that’s fine.

As for the Saving a project at any stage. It happens regardless if a project gets saved or not. I am able to open old projects and have the same issue now occur for them just as if i was starting a brand new project and had not saved it yet.

It just seems so random for this to start happening. It was working just fine a month or so ago, i had no issues then at all.
What could possibly cause something like this to happen all of a sudden?
:frowning:

I think we are trying our best here. It isn’t easy if it doesn’t happen for us.

You haven’t really given us exact steps. We don’t know exactly how you get the cursor to the point where you start recording the second track, we don’t know exactly what point that is, or what button or menu you use to start recording or how long exactly the new recording is. We don’t have the exact song that you import.

What happens if you record only two seconds? Does undo remove all the track then? It looks as if your recording may be longer than one block file and that Audacity may be trimming back only to the previous block file.

Have you tried just deleting the tracks you don’t want?

What have you changed on your system since this problem started? Have you tried System Restore?


Gale

Yes, there is the option to delete the tracks instead of Undo them but the Undo function tends to be better house-keeping than deleting, i find. It’s just the way i’ve worked all this time and never had any bugs or issues with that method, until now.

Exact steps are:

  • i load instrumental in to Audacity
  • i use my mouse to select and click where i need to start recording
  • i press R to being recording
  • i record for a full verse (anywhere between 30 to 50 seconds)
  • i press space-bar to stop recording
  • i press space-bar again to listen to what i have recorded
  • once i have listened to it i press ctrl-z to undo the recording
  • the undo-bug issue occurs

In regards to what i’ve changed on my system since the problem started, the only three things i can think of that’s happened to my computer are the following:

  • i installed a service called Steam (it’s a video game service) and downloaded some games, (though i really can not see this being the issue somehow)
  • i added some new Ram to my computer
    and
  • i bought a brand new microphone a few days ago and upon plugging it into my computer it installed some drivers, as expected of all new hardware.

Aside from that, i’ve not really done much else to my computer between the time i last used Audacity and today.

You said two things that caught my attention. “It’s been working for a long time and suddenly this trouble.” On the video forums we silently attach “…when I filled up my hard drive.”

If you get tired of blank looks from nine time zones, pull the new memory out (carefully) or subject it to a good extensive memory diagnostic.

http://windows.microsoft.com/en-us/windows7/diagnosing-memory-problems-on-your-computer

You used to be able to run this test looping all night. Highly recommended.

Probably simpler and faster to pull the new memory out and see if the problem vanishes. Audio and video production software tends to use high memory.

Koz