Unanticipated host error with Focusrite Saffire 6 on Win 10 [SOLVED]

I have the following setup:
Windows 10 Pro
Audacity 2.3.2 set to Windows Direct Sound, Stereo Recording 48k sampling with 24bit resolution.
Focusrite Saffire 6 USB used both as input and output, sound settings → advanced reports above sampling and resolution figures as standard settings

My problem is: I can record exactly one track, I can stop recording and then resume recording.
BUT, I cannot create any new tracks and record on those (overdub).
As a sidenote: overdubbing used to be the default behaviour, now you have to press Shift-R, wtf??
The error I see is the dreaded “Unanticipated host error” followed by “Error while opening the recording device. Error code 0 Success.(very sarcastic message, by the way)

What I have done so far (without changing the issue in any way): I checked sampling and resolution between Windows sound settings properties and the settings of Audacity and aligned those as written above.
In transport options I have checked that overdub is on and the software option is off. Turning overdub off “solves” the problem in that I can record many tracks as usual but I do not hear any sound of what has been recorded before, obviously.
I have redownloaded and re-installed the “Focusrite USB driver 1.10.exe” from https://customer.focusrite.com/support/downloads.

What is weird is that all others postings that I have read that had the same error messages could not record at all, while I can record one track but cannot add any others.

I have used this exact setup for many years without ever having any issues or configuring anything - it just worked out of the box. But after some update of either Windows or Audacity I started experiencing this problem.

Fun fact: the problem disappears, if I set my Webcam as the input device (and leave Saffire as the output) - then I can record as usual, including overdubbing. Obviously, my webcam microphone is not the device I want to use for recording though.

If anyone has an idea, let me know :slight_smile:

now you have to press Shift-R, wtf??

While it was working the other way, thousands of people complained that Audacity didn’t just pick up where it left off which everybody knows is the Way It’s Supposed To Be.

You can change this default behavior in Audacity Preferences.


Just to cover it, does recording work if you use anything else but the Focusrite for playback? I know that’s not the eventual goal, but it’s Not Good to ignore any symptoms or conditions during a repair.


You can change this default behavior in Audacity Preferences.

Thanks for the hint.

Just to cover it, does recording work if you use anything else but the Focusrite for playback?

I’ve tried two things:
1.) I selected some “primary sound driver” as the playback which did not change a thing - I do not know what that even means
2.) I’ve connected my screen with HDMI (instead of DVI) which enabled the screen as an additianal playback device. Now, selecting this while keeping the Focusrite as the input actually works.

What does that tell us?

Additionally, I also tried removing the current Audacity installation and installing older versions, 2.2.2 and 2.1.1 but that did not change a thing.
Also I tried plugging the Saffire into a different USB port, also no luck.

So did some Windows system upgrade break everything for me?

Did you check the Recording AND the Playback settings?
(We’ve had a number of reports that suggest that recent Windows updates are a lot more fussy about sample rates matching).

You saved my day, problem solved! :sunglasses:

It never occurred to me that there are three things to be aligned:

  • the sound settings for recording device
  • the sound settings for playback device
  • audacity settings
    all have to agree on sampling and bitrate. I somehow only checked two of those :confused:

Thanks a lot! :slight_smile:

Super :slight_smile:
I’ll close this topic as “solved”