Unable to use streaming recorder with Realtek [SOLVED]

OS: Windows 10
Sound Adapter: Realtek HD Audio - driver rev.
Audacity rev: 2.1.2

I’m trying to get Audacity streaming recording working. Whether I use MME or WASAPI, when I click the monitor button, no sound is being captured by Audacity. (Same result when recording; just get a flat line.)

I discovered that if I go into the Realtek HD Audio Mgr and disable the speakers as the default device, sound is captured by Audacity (both MME/WASAPI), but of course there is no sound from the speakers (and worse, I have to uninstall/reinstall the Realtek driver to get speaker sound to work again).

I’d appreciate suggestions as to what might be wrong with my setup.

If you have to reinstall the Realtek driver to get speaker sound back (rather than just re-enable Speakers in Windows Sound) that suggests to me a problem with that driver. Is this a branded computer like Dell or Lenovo, and if so did you go that manufacturer’s site and get the latest Windows 10 driver for your computer model?

Also when you choose Windows WASAPI host, are you choosing Speakers (loopback) for Recording Device? That is the best choice to try first.


Thanks Gale.

I have solved the problem. Shortly after upgrading to Windows 10 I purchased a new monitor with integrated speakers that connects via a DVI/HDMI cable. I only had to switch the recording and playback devices from Realtek to MX279 (Intel Display Audio).

I will mark the topic [SOLVED] then and lock it.

To me though it sounds like the Realtek audio is broken, should you wish to use it.