Unable to Use Audacity on Win 10 [SOLVED]

Recently I was “forced” to accept the Win 10 upgrade. (It showed up on my PC after I left the PC on overnight.) Now I can’t use Audacity (V2.1.2. which was installed via an .exe). I’m having trouble navigating around Win 10 due to some of the cosmetic changes they made, so it’s been difficult to sort out what has happened. (FYI, Adobe Audition also no longer works.) I’ve tried to uninstall/reinstall sound controllers and speakers, but the PC doesn’t even recognize my speakers. Is anyone else having issues with Win 10 like this? If so, how did you get past them?

“If you don’t behave yourself, young man, we’ll put Windows 10 on your computer!”

It’s a given that many hardware devices and software packages only work when they’re specifically Win10 compliant. So this is where you go to your manufacturers web pages, Adobe, etc, to find updated drivers and software.

I am a little surprised they’re forcing the “upgrade” now. Several people have woken up from a sound sleep to discover they are now running Win10 with no further effort on their part. Also, you used to be able to roll it back. I’m assuming you can’t any more?

Is anyone else having issues with Win 10 like this?



I found [u]Going Back To Windows 7 or 8.1[/u].

You’re the 2nd person I’ve read about who got automatically updated.

Microsoft recently changed the “Update to Windows 10” app so that clicking the red window Close button on the dialogue amounted to the user saying “Yes” to the upgrade. They have now stopped doing that, I believe.

If you stay with Windows 10 you will have to look on the web site of the computer or motherboard manufacturer for the latest Windows 10 audio drivers intended for your computer model. See http://wiki.audacityteam.org/wiki/Windows_10_OS#drivers. If after that Audacity says “Internal PortAudio Error” and sees no devices, try Audacity 2.1.3-alpha.

By the way, there are third-party methods to remove the “Get Windows 10” nags. However after Windows 10 becomes paid-for in August, Microsoft say they will remove that update app anyway.


OK…Here’s where I’m at so far:

I did as the Microsoft Community agent suggested and ran the troubleshooter (again). The device (Realtek Hi-Definition Audio) was found. The drivers are up to date and it is (supposedly) working. However, the “properties” info box for the device says “Requires Further Installation.” No “enhancements” were on except for the “Immediate Mode” box being checked. Under the “Advanced” tab, it said “16 bit - 44100Hz,” which also sounds OK. When the troubleshooter was finished, the dialog box said “Audio Services Not Responding.”

I opened Audacity to see what impact my efforts had, but the Playback Device box is blank. I could not get a song to play and Realtek does not show up as a choice in the “Playback Device” box in the toolbar. (I was unable to find any selections with which to fill in this box. I also tried to open Audition, but now it won’t even initialize. To compound matters further, now I can’t play music on apps like WMP, or Groove (the new music player app found on Win 10), which worked yesterday.

I’m going to continue working on this now and I’ll update you folks later.

Last, I currently have inquires open on forums for Adobe, Audacity, Microsoft and Logitech (the maker of the speakers), so I am asking around.

Well, I was finally able to sort this issue out. I did a system restore and found the “lost” sound device. I then selected it as my default and disabled all enhancements. I opened and checked Audacity and saw that it had been added automatically as the Recording and Playback devices. I opened up a .FLAC and then a .MOGG file and they played as they should. I’m still not 100% sure how this all got messed up, but it is now sorted out! Thanks to all here who offered advice!

It seems they now removed the closing button… (the X). So the choice is “Yes, immediately” or “yes, later”…

I never saw this problem on Windows 7 because I removed the Windows Update item that implements the update application soon after it was originally installed.


So presumably the System Restore doesn’t return you to Windows 7 (I don’t think that is possible) but there were restore points there for after Windows 10 was installed?