unable to use any menu

When I click Help > About Audacity, nothing appeared. I ignored this and proceeded to record a podcast nonetheless. It turns out that this is not as benign as it appeared at a first glance, since I’m unable to save the recording (nor project). When I click File > Save Project or Export, Audacity becomes unresponsive (i.e. nothing is clickable). After pressing ESC control is resumed. This happens to most of the menu items I tried except Print (I have not tried printing my audio recording due to its limited use).

Is there a silver bullet for this? It occurred to me that I can copy the temporary files to a different folder, rename the files and do a manual restore, but was hoping something less hands-on.

After clicking Submit I realized I haven’t provided all the details. I’m on 64 bit Windows 10, Audacity is 2.1.0.

Luckily I had the recording backed up by recording on my smart phone (finally lived up to word “smart”!). I decided to test my fate and closed Audacity. It became unresponsive and I pressed ESC. On the second try, a prompt asking me if I really want to close appeared. After clicking “yes”, I was offered to name the file and upon hitting Enter Audacity became unresponsive again. Hitting Enter save the project and closed the program. When I reopened the .aup file I could go to File > Export Audio and normally save .wav file. I think I’ll try the latest version now.

Have you opened Windows Task manger and looked at CPU usage or RAM remaining?