Unable to save project or extract mp3


I made a mashup of several different songs to be used in a dance show. First when I try to save the project, it doesn’t work as I just get the message “the file xxx cannot be found” whatever I try to name the project.
The same happens when I try to export the song as an mp3 - first it will say that it cannot find the file when I try to name it, and when I try to choose a song file that is already saved it will ask if I’m sure I want to overwrite it and then it seems like it’s working until the very end where it just says “unable to export”.

I have allowed audacity.exe through Windows Firewall as well.

Has anyone had similar issues and know how to fix it?

Thanks in advance <3

Did you put punctuation marks such as date slash marks in the filename? Don’t do that. Use ISO dates such as 2019-03-31. Dash and Underscore are allowed.


No, I didn’t use any punctuation. Literally whatever I write doesn’t work

It solved itself. For anyone else having a similar problem I’ll just write what happened.
I had to restart my computer cause it froze (never happened with this laptop before) and when I opened Audacity and expected everything to be lost, it had restored my project and now I am able to both save the project and export the song.
“Have you tried turning it off and on again?” clearly worked here :laughing: