Unable to save project or export to file

I am using Audacity 2.1.1 from DMG on iMac runing OSX 10.7.5
I have been converting old cassettes to digital files and loading them into iTunes without any problems (about 2 dozen so far) however I recently imported a commercially recorded cassette (the import went fine and I saved the unadulterated file without a problem). After this I opened the file and tried to edit it. Each time I tried to apply an effect the segment I was working on disappeared entirely. It came back if I clicked “unedit”. I tried to label the tracks without editing the audio and then save the project and Audacity would not let me save the project with any changes. I then tried simply to export the labeled audio to a file using “export multiple” and got a message saying “unable to export to file”.
That is the main problem.
More info is that after closing that file the same glitches appeared when I tried to edit and export files I had made from personally recorded cassettes. This had not been a problem for 2 dozen previous as noted. So I gave up and shutdown the computer and had dinner. I came back and tried the personally recorded cassette and had no problems. That was last night.
This morning when I tried the commercially recorded cassette, I had all of the same problems. I went to a laptop and tried the personally recorded cassette files and also had no problems. I am reluctant to try the commercially recorded cassette files on the laptop.
Is there some sort of copyright issue that has been digitalized from the cassette that has caused this and maybe I just need to pitch that file or does anyone have a suggestion about something I might be missing? Seems odd that it would affect subsequent files that otherwise are no problem.

Thanks, Jeff

Look at Audacity > Preferences… then the “Directories” section. You must have permission to write to the Audacity temporary folder listed there and the drive must have sufficient space.

You can look at Help > Show Log… to see the errors that are occurring.

If your Mac permissions have broken, as a first step, open Finder, use Go > Utilities > Disk Utility > to open Disk Utility then do Verify Disk. Then do Repair Permissions.


Thanks Gale,
It shows a “live” path to the directory so I assume that it is good. There is about 1.4 TB so should not be a problems there. I attached the log as you suggested. I don’t understand it. As for the disk utility, would that be a problem even when all the other times it works well?
Thanks again.

log.txt (3.45 KB)

And what is that path? Click in the “Location” box in the Directories Preferences until you have selected all the Location text, then right-click or CTRL-click and choose “Copy”, then paste the path in here.

It shows Impossible to get permissions for file ‘/Users/jeffreytlenert/Library/Application Support/audacity/pluginregistry.cfg’

If Audacity can’t write to some or all of your own user space you will be stuck.

If I were you I would open Disk Utility and run the commands I suggested.

If you need more help after running those commands please tell us exactly what files the commercially recorded cassettes are on and where those files are located. For example, are they AIFF files or AUP Audacity project files that are on your Desktop?