Unable to record sound on Mac

MacOS: Catalina 10.15.2
Audacity version 2.3.3

I am first-time user of Audacity, have recently downloaded Audacity.
Tried to record my voice without success - recording commences but no sound waves appear and the recording playback is silent.
Audacity - preferences - devices - have checked this, here is the information - host: core audio; Playback device: built-in output; Recording Device: built-in Mic, Channels: 2 (stereo); Latency buffer length 100 ms, compensation -130ms.

Looking at my Mac system preferences, security and privacy - Audacity does not even appear on the list of apps to allow to access my mic.

I have followed the instructions for downloading and accessing the Audacity app.

Have contacted Apple who advise its not an Apple issue (my mic is working).

I would appreciate your help.

Many thanks

That’s not entirely true.
It’s true to say that it is not due to an Apple “bug”. The problem is due to a new, deliberate “feature” in Catalina, which is that Catalina prevents Audacity from accessing the microphone because Apple have not “approved” Audacity (the technical term is “notarization”).

Fortunately there is a workaround, though unfortunately it’s a bit awkward. See: https://forum.audacityteam.org/t/audacity-2-3-3-under-macos-10-15-catalina/54279/1

It is hoped that the next Audacity release (due in a few months) will be approved by Apple, and so not have this problem.

Many thanks, the work-around worked!

I look forward to the next Audacity update which will remove the need for the workaround.