Unable to record or playback on USB

We have been using Audacity (currently 2.0.4) on an old XP desktop computer for our Mackie 3204 Digital Soundboard at church for about a year. Prior to that we used a non-digital soundboard and Audacity for several years.

We received a donated 1 year old Toshiba laptop with Windows 7 installed, and wanted to upgrade to the faster computer with more memory and a much bigger hard drive.

I have installed Audacity 2.0.4 and the Mackie drivers. The VLZ3 shows up in the input and output selection options.
There is no input registering from from the sound board and nothing playing back on Audacity plays into the soundboard.

Other programs, e.g. Windows Media Center play back just fine.

I’m back to using the old computer, which still functions, but I’m not too sure how much longer it has and I would really like to be able to use the new computer.

Any suggestions would be gratefully appreciated.

Fran McHugh, Sound Booth Beginner
First Baptist Church, Winslow, AZ

How is the Mackie connected to the computer?

Win7 has a few more hoops to jump through to get routing right.

Audacity > Edit > Preferences > Devices

This is where I run out of steam since I’m not a Windows elf, but if you’re using your built-in soundcard, then Audacity should be pointed to that, both recording and playback.

This depends on the answer to question one.

You in particular should not be using Stereo-Mix or any of the services that connect Record and Playback to each other. That can cause feedback and other problems.


The output and input are directed to the Microsoft Sound Mapper (the only other options are the mic and speaker) and it is set for Mono.

The laptop is connected via the USB port to the USB port on the back of the Mackie sound board.

If you don’t see USB Audio CODEC in the Audacity playback and recording devices, do Transport > Rescan Audio Devices.


I am going bonkers. I have tried everything I can think of and even some things unthinkable. :blush: I went a step further. I brought my MacBook over and hooked it up to the sound board. It shows the VLZ3 just fine. It can play back from Audacity recordings just fine. However, it is also not seeing the sound coming in from the sound board. Anything I can load into Audacity will play out, but nothing comes in except through the built-in mic.

I also tried recording with a USB turntable. There were some minor issues with input volume being seriously over the top, but I was able to record on both laptops from the turntable.

Why doesn’t Audacity recognize the signal coming in from the soundboard? This is version 2.0.3 if that matters at all.

Help! I’m willing to buy a new computer if that’s what’s needed, but if I can’t get either of these to work I have no confidence that I’d have any better luck with a new Win8 model. This old tower is not long for this world and we’d really like to have something else in place before it hits the dump.

2.0.3 is obsolete now. You should get 2.0.5 from http://audacityteam.org/download/windows but it won’t help if you are not routing the sound from the mixer correctly.

Right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the mixer then choose “Set as Default Device”. Right-click over it again, choose “Properties” then the “Levels” tab then turn the input level up. Then record with Windows Sound Recorder. Does it record the signal?

Have you read the Manual for the mixer? That often helps.