Unable to record from computer Windows 7

I used Audacity happily with XP for a number of years,usually recording spoken word/interviews from various sources via the internet.

Since having Windows 7 installed ,and reinstalling Audacity (version 2.0.5) I have been unable to record anything.

I have tried different combinations fron the Audacity tool bar (MMN or Windows ) and the same for the input next to the mic. symbol without success ( but I am not sure what they should be set to any way)

Any advice any body?

Have same problem installed it one hour before, i had reinstalled windows yesterday.
PS. now i have win 7

For Win7, try WASAPI Loopback as described on [u]this page[/u].

Thank for your helpful reply.
I have tried the settings as described in the link which you kindly provided and it will record, but the recording level is really quite low and there is no means to increase it via the input slider, is there another way to increase the recording level you know of?

Try increasing the playback level of what you are recording (and turn down the level of your speakers if you have external speakers).
If that doesn’t work, use the Amplify effect when the recording is completed.

Thanks to Doug and Steve, your advice has solved the problem.(hopefully Moder_20 aswell)

If you don’t have external speakers, just start the playback of what you want to record loud enough to get a good level in the WASAPI recording. You can then turn down or even mute the playback device slider in Windows if you really don’t want to listen while you record.


Inspite of the fact that I thought this problem solved,it is not.
Set to wasap with the other settings as desribed in the tutorials,and with the output from the thing being recorded from (usually BBC R4 player)set to maximum,still the recording level is low and is not affected by the playback slider or the volume of the speakers on the computer(no external speakers)
Any ideas?

What is the maximum peak level of the recording? If the peak is very low (below +/- 0.5) try left-click on the speaker icon (by the system clock) then click “Mixer”. Play your stream in the web browser then in the Volume Mixer, turn up the volume slider for the Flash player.

Otherwise, try the previous suggestion of Amplify after record.

If Amplify is not loud enough for you then you will have to use Compressor to reduce the dynamic range, so that all the content sounds loud.