Unable to record from any source

I recently upgraded my Mac to 10.15.2 (Catalina). At the same time, I installed Audacity 2.3.3. After doing so, I cannot record from any source.

When I try to record, there is no error message, but the display shows only a flat line and no sound is recorded.

I have three sound sources on my Mac (built-in microphone and two USB devices). The devices themselves are recognized by the OS and appear to be working fine. For example, if I play audio into one of the USB devices and I select that device in the Sound preferences, I can see a response on the audio meter. Also, my microphone works with other apps.

I looked at the microphone privacy settings in Preferences and Audacity is checked. I tried un-checking and re-checking it, but that didn’t help. I also tried rebooting a couple of times.

I’m not sure where else to look or what else could be going wrong. Any ideas?

Thanks,
Frank

https://forum.audacityteam.org/t/audacity-2-3-3-under-macos-10-15-catalina/54279/1

Koz

You’re doing yeoman’s work, Koz. Thank you.

Thanks, launching from Terminal worked for me.

Any idea what is causing this problem or when it will be fixed?

what is causing this problem

You are witnessing Apple hardening itself to renegade automatic connections. Instead of just blindly connecting to anything that wants access, the machines now take steps to make sure the actual user is out there. It’s Apple’s version of “Prove you’re not a robot.” Unfortunately, one of the ways Apple is hardening itself is carefully peeling off apps and programs that don’t originate or are sourced by Apple.

As I understand it, Audacity’s daddies are working with Apple to resolve this. It’s more scary than you think because there are a number of third-party programs that Audacity uses so it can present as a complete, stable program without having to write everything from scratch.

Lots of feverish activity at the Audacity Land’s End World Headquarters.


AudacityHeadquarters-500T.jpg
Koz

it looks that Audacity 2.3.3 don’t ask for access permission if your Mac does not have any built-in microphone input.
Running Audacity on Mac mini (late 2014) with Catalina. Audacity doesn’t appear in System preference panel > Security and Privacy.
I’m connecting my audio device to analog input with 1/4 inch mini jack.
Quicktime can record sound as Garage band.
In Audacity I 'm able to select the integrated input but nothing happen in the monitoring bar meters or when I hit record.

It’s actually down to the border fences that Apple is busy erecting.

Apple now require an app to be “notarized” - i.e. officially approved by them before that app can be granted access to devices like the mic input.
(Basically they’d prefer all apps run on Macs to come from the Apple Store - to give them more control.)

We are busy working on that - in fact I have been QA testing the 2.4.0 Mac alpha - and I confirm that this works properly to access the mic. The wortk to do that has unfortunately thrown up a couple of bugs elsewhere which we are working to fix.

I am confident that it will be fixed for 2.4.0 release currently planned for late Q1 2020.

In the meanwhile the exists this workaround: https://forum.audacityteam.org/t/audacity-2-3-3-under-macos-10-15-catalina/54279/1

WC

Quicktime can record sound as Garage band.

Both native Mac Apps.

Koz