Unable to record desktop sound


As the title says, I am unable to record desktop sound through Audacity.

Some information:

  • I use Windows 10
  • I use Audacity version 2.1.2
  • I used to do this fine using a headset called the Creative ChatMax HS-720. These are the settings I used: http://imgur.com/a/SpONa
  • I am now trying to do this with a headset called Plantronics GameCom 788
  • These are the settings I’m attempting to use: http://imgur.com/a/nRLO9.
  • I’ve tried a few different combinations and either nothing gets recorded or I get an error

Thanks in advance

Thanks for the details.

Have you installed the “Plantronics GameCom 780/788 7.1 Surround Sound Software”? Virtual surround sound could be the difference between this headset and your previous headset. Also be aware that software does not claim to support Windows 10. If you have installed that software, check if the number of recording channels in Audacity can be set to 8. That works with some virtual 7.1 surround sound headsets.

If you need more help, please go to Help > Audio Device Info… top right of Audacity, save the information and attach it.
Please see how to attach files to forum posts.


I have indeed, and yes that’s a very good point.

Yep, I’m using beta Windows 10 software for it.

Maximum seems to be 6. Judging by the soundwaves it did record, but I try to play it back and it throws up the error. You can turn Dolby off on this headset but seems not to make any difference in relation to this issue.

File attached, cheers.
deviceinfo.txt (9.01 KB)

The Audio Device Info says maximum six channels too.

Recording six channels may be what you will have to do unless you are willing to uninstall the virtual surround sound and manage with two recording channels (stereo).

As for getting the six recorded channels to play, all Audacity playback is mixed down to stereo. The simplest solution is probably to change to MME or Windows DirectSound host in Device Toolbar just for playback. These hosts only support two channel playback so there is no conflict.

If you want to avoid that hassle of changing host, you could try right-click over the Plantronics playback device in Windows Sound, choose Properties then click the “Advanced” tab. Choose a “Default Format” that has the same sample rate as your project rate bottom left of Audacity and uncheck the “Exclusive Mode” boxes. Restart Audacity. If Audacity playback still errors, try enabling the “Exclusive Mode” boxes and restart Audacity.

If playback still errors you may not be able to do anything short of setting two channels in Default Format, which you may not want to do. Perhaps if you mixed the six recorded channels down to stereo in Audacity (Tracks > Mix and Render) it might help. I don’t know if you were wanting to export a multi-channel file from the recording.


I absolutely don’t mind using two channels, all I’m doing is recording part of a song when necessary, so I can loop it as it makes what I’m doing easier sometimes.

When I get the chance, I’ll run through your post.

Thanks for the help