unable to record anything

I’m running Windows 7 on a desktop PC. I have done a fresh install of Audacity 2.0.5 using the exe installer. I am using a headset mike/headphones plugged in to the front jack sockets of the PC. Checking Windows > Control Panel > Hardware and sound > Sound > Manage Audio Devices > Record I can see that ‘Front Mic’ is selected as the default device (and the ‘blue bars’ are shown alongside it). Clicking the ‘Front Mic properties’ tab and choosing ‘levels’ I have set the ‘Front Mic’ level to 100 and the Microphone Boost to +30dB. If I alter the boost, I can hear the change in level in the headphones, which suggests that Windows is correctly receiving input from the sound card.

If I speak into the mic I can hear myself on the headphones, and the playback volume changes if I move the slider at the top of the Audacity window. However, I cannot get any reponse to the input level monitor, and if I click the record button I get the message ‘Error while opening sound device’. Using the Device Toolbar I have selected MME / Speakers (VIA Hi Def A) / Front Mic (VIA Hi Def / 2 (stereo) input all of which I think is corrrect. I’ve also read the manual!
What have I not done?

Try changing the Audacity Preference settings:
Devices > Recording > Stereo or Mono (there’s no way to know – try both)
Quality > Sampling > 44100, 16-bit.

Most devices support that and it’s a good place to begin.


Thanks. Sampling was already set to 44100Hz, and I have now changed to 16-bit. It didn’t solve the problem. I also tried both Stereo and Mono recording modes but still cannot detect any input sound.
I am particularly puzzled by the fact that the output level varies if I move the speaker slider at the top of the Audacity window, but I cannot monitor the input or output level with the meters.

Is there a ‘standard way’ to test the system?

:frowning: Keith.

Some further information. When I place the cursor over the input or output level meters, it displays as a double ended horizontal arrow (the cursor used to alter the length of the window), and not the pointer. Therefore I am not able to ‘left click’ the meter. If I place the cursor over the left end of the meter area I can drag the meters elsewhere on the screen and I then see a pointer cursor, but I still can’t get any response to left clicking the meter. However, I can, in all circumstances, get a response to left clicking the button alongside the microphone symbol, to reveal the drop down menu (‘disable meter’ etc).

Without enabling monitoring in Audacity you shouldn’t be able to hear yourself when you speak into the mic, unless you had unmuted the mic from the Playback tab of Windows “Sound”, or enabled “Listen to this device” for the mic from the Recording tab of “Sound”. If you right-click over the recording meter, and you see “Stop Monitoring” then you are monitoring.

That’s a known Audacity bug, but it will go away if you click in the grey background in the project then move left and right over the Meter Toolbar drag bar a few times without dragging.

To fix the “error opening”, you could visit Missing features - Audacity Support and try the “Alternative settings” using Windows DirectSound shown in the green box a few scrolls down. You can stay with 44100 Hz project rate in Audacity and 16-bit quality for now, but in practice setting Audacity to 32-bit float almost never causes “error opening” even though there are almost no 32-bit sound cards.

If there is still the error after that, then you should look at updating your sound device drivers .


The problem was somewhere in the Alternative Settings. I have followed your advice and, after quite a lot of fiddling, I can now record from the mic, so I think I am ‘on a roll’!
Keith :smiley: