Unable to post to the forum - Solved.

In case anyone else has this problem;

I was connecting to the internet from my laptop using a wireless connection to a Belkin ADSL wireless router. Everything appeared to work correctly except for posting to the forum. When attempting to post, the connection would time out, then I’d get a message asking if I wanted to download a .php file.

The problem turned out to be a firewall issue between the laptop and the router. When connecting to the router, the router would send an ICMP “MS Traceroute” message to the laptop, but the laptop firewall blocked this message. This did not prevent the laptop from connecting to the internet, both e-mail and web browsing worked, but posting to a phpBB (the software used by this forum) did not work.

If you have the same issue of being unable to post to the forum when connecting by wi-fi, it may be worth checking your firewall settings.

[Update] A note from the Audacity forum administrator about this:

There are some ‘security experts’ out there saying: “filter ICMP”, when they should be saying “only
filter those specific ICMP subtypes that are NOT related to NETWORK STATUS”.

Filter ping if you want, but never filter fragmentation, routes, etc.