Unable to play sound through headphones whilst recording

When using a Tascam Zoom H-1 recording device, I find myself unable to hear recorded tracks through my headphones, which use a basic audio jack. However, the sound I’d like to be hearing through said headphones plays through the tiny and rather inferior speaker built into the recorder. Is there any way to rectify this?

I’m currently using the latest version of Audacity with a fully updated version of Windows Vista, all on a Toshiba laptop.

Audacity > Edit > Preferences > Recording > [X] Playthrough (select) > OK.

You may find that live recording is awkward because the headphone feed is almost always late compared to the real show and it gives you an echo. Also headphones are required if you have a live microphone.


So you’re suggesting that I forgo the whole live recording thing by recording a track separately, plugging the recorder in, dumping its contents, then repeating the process? It’s something I’ve considered, but I really don’t like it.
Is there any possible way to redirect the sound output? Would I have to purchase a set of USB headphones or something to that effect?