Unable to overdub using USB soundcard

Hi. This post relates to Windows 10, and Audacity 2.2.1.

On a new Dell laptop, I am using a Behringer USB soundcard (UCM202HD), and installed all the drivers from the Windows 7-10 driver package from Behringer. The device appears in Device Manager with the correct name.

It records one track fine (mono or stereo), but as soon as I try to record a second track while listening to the first, it just doesn’t do anything. The new recording track doesn’t start, the cursor sits at the beginning and nothing happens. This is with Audacity set with input and output both to the Behringer.

However, overdubbing using the Behringer input works perfectly when I change the OUTPUT to the laptop’s built-in speaker.

I have tried uninstalling the device through device manager, and using the driver uninstall package, and also I have tried different USB ports, but the result is exactly the same.

I also tried a much older Audacity (1.something) and the result was identical.

Weirdly, the Behringer card works perfectly on an older Dell laptop (running Windows 7), same drivers, same Audacity installation.

Does anyone have any ideas?

Thanks so much.


It’s UMC202HD.

What’s the job?

Do you have it set for stereo? The UMC202HD is a native stereo device. I have devices that don’t like crossing Stereo/Mono. That’s why knowing the job is important.

I expect you to be able to play a stereo song in Audacity and hear it in your stereo headphones on the UMC202HD. And then as a separate event, record in stereo from the UMC202HD. When overdubbing fails as yours has, I expect one of the two services isn’t set up right.

If you set everything up correctly, I wonder if you need the drivers. The drivers may be causing problems because in Windows 10, you are required to use Windows 10 drivers. Earlier software may not work right.

But a normal stereo Behringer unit should not need drivers.


One more possible problem.

Do you have a mixture of USB2 and USB3? Try switching to a different USB port. Audacity will “lose” the device when you unplug it. Restart Audacity or Transport > Rescan…



Thanks a lot for the speedy reply, and you’re quite right, it’s UMC…

The job was really just checking the new unit worked properly. You’re quite right that I can play a stereo song through the UMC, and I can record a stereo song (or a mono one, it doesn’t seem to make any difference), but it’s the playing a previously recorded track and then overdubbing that messes up.

I suspect it’s a Windows 10 thing, because the old Windows 7 machine got the identical process of installing and testing, and worked like a charm first time.

I will try your suggestions this evening, as I think there is a mixture of USB ports. I will also try uninstalling the drivers and see what Windows comes up with. The Behringer site has a specific set of drivers labelled “Windows 7-10”, which is what I’m using, but I’ll see what happens.

Thanks again.


“Windows 7-10”

That’s good. It has to say Windows 10 somewhere.

you’re quite right, it’s UMC…

The elves have to extrapolate a set of circumstances from the limited information in an initial posting. We hang on every word and accuracy is good.

When Audacity hangs like that, it usually means it’s not getting data. In the case of overdubbing, it could mean a data failure either direction.

It’s good to know that the setups for recording YouTube sound and overdubbing are very different. Recording on-line content produces a special “fake device” to do unusual sound routing. The fake device won’t work with overdubbing. Both the input and output have to say (from memory) USB Audio Codec.

Are you getting your setup from the tutorial?




So, tried some stuff. Tried different USB ports and it made no difference. Complete uninstall of drivers and Behringer drivers package, then plugged back in, and Windows installed the device “UMC202HD 192k”, but it says driver unavailable. Device Manager cannot find any drivers.

When I tried this it recorded audio, but as soon as I tried to record a second track I got:

“Error opening sound device. Try changing the audio host, recording device and the project sample rate.”

Installing the drivers properly again has gone back to the problem I had before.

My setup should be fine - I’m using identical Audacity, Behringer software/drivers/settings on both laptops, and the recording setup is identical. The only difference is that one is Windows 10 and the other (working one) is Windows 7.

Could it be that the very first time I tried to install the Behringer drivers something messed up?

Could it be that the very first time I tried to install the Behringer drivers something messed up?

You are oozing into foreign territory. I’m not a Windows elf and I don’t know the particulars of driver health and configuration.

When you had all the drivers ripped out, did the UMC work? Both directions? Plain,ordinary stereo recording and playback should be handled by generic internal Windows configurations. People have been doing that for centuries. It’s only when you get into special purpose tools like multi-channel or odd volume adjustments that you need the drivers.

A note that Audacity gets its sound from Windows, not the device. You should be able to troubleshoot this with the Windows control panels and leave Audacity out of it.

Right click the speaker lower right > Recording.

The UMC should work perfectly with any playback on the machine and recording should appear on the panel’s bouncing sound meters. You have to be able to say those words before you launch Audacity.

You could have something odd like sampling rate problems, but that’s unlikely if you’re using 44100 or 48000. Does the UMC prefer one over the other? 44100 is the audio CD standard and 48000 does video. Both ordinary as dirt.


It records one track fine (mono or stereo)

Fascinating. There is a sister posting who can’t get Solo to produce a mono recording into a stereo track. I suspect that’s what the drivers do. I suspect without that, you either get a mono show—one blue wave—or stereo show with your microphone on the left. Full stop. The drivers allow you to create Two-Track Mono which is not “natural.”

The question is what happens when you try to play a two track mono show back into the Solo for overdubbing. I wonder if the drivers fall over.


Using Windows 10 and Behringer U-Phoria UMC202HD. I have the drivers for the Behringer installed and they specify Windows 10.

I can import an audio drum track and it plays through fine. I can import the second track and it plays through perfect, but the following message appears after I try to record a track using my Behringer.

Latency Correction setting has caused the recorded audio to be hidden before zero. Audacity has brought it back to start at zero.
You may have to use the Time Shift Tool (<—> or F5) to drag the track to the right place.

When I click record, the red bar stalls and recording doesn’t happen.

I’m very new to the home recording process and I don’t have a full understanding of setting up this system. I just know that I want to monitor what I am recording as I play. Any support for getting this setup would be greatly appreciated.

Digital Amnesia: I am having exactly the same problem you described. Behringer 404 connected to new windows10 laptop. I can record the first track, but when I go to overdub, I can not hear the first track. If I activate “overdub” in the settings, I now can NOT record the second track, because it stalls and does nothing exactly as you described. I can not figure it out. Have you had any luck with this issue? I’m guessing it’s user error, but I have looked over everything a hundred times.

Ensure that you are using the same sample rate throughout.

  • The “native” sample rate for the Behringer 404 is likely to be either 44100 or 48000, so try both of these.
  • Check the sample rate for recording and playback for this device in the Windows Sound Control Panel.
  • In Audacity, set the default sample rate to match (in “Edit menu > Preferences > Quality”).
  • Ensure that the “Project Rate” (lower left corner of the main Audacity window) also matches.