Unable to open target file

I have just installed Audacity 2.1 on my new MacBook Air (OS 10.7.4) and also installed LAME. I have recorded a project with two tracks and can export them to MP3s as separate files using the Export Multiple files but when I try to export them as one file under Export, I keep getting the error message “unable to open target file”. Given that I can export them fine as separate files, why can’t I do so as one file with both tracks?

Does anything in this topic help? https://forum.audacityteam.org/t/opening-target-file-for-writing/24678/1

No - I had already looked at this. I am the only person with permissions on this computer and the name of the file is Carlito - no numbers or dashes or anything. And it does work just fine if I record it as multiple tracks.

The other thing in that topic: did you try clearing the Metadata?

yes I did that also.

I have recorded a project with two tracks

Just to clear this, you have two tracks left to right, or two tracks one above the other?

If they’re one above the other, MP3, as I understand it, doesn’t support multiple stereo track export.

But WAV does. File > Export > Other Uncompressed Files > Options. I did this once and I don’t remember how I did it.


I recorded an audio track and then put some music behind it and they are stacked on top of each other. That’s what I’m trying to export. Can you not do that in Audacity? And if I export it as a WAV file, how do I then cnovert it to mp3?

I just tried exporting it as a WAV file and it didn’t work either. This is using a MAC and it said WAV (microsoft) 16 bit PCM. I also tried the AIFF (Apple) format.

I’ve got a feeling this will turn out to be something really obvious that we’re all missing. At the moment it just doesn’t make sense.
Let’s start by resetting the Audacity preferences: http://manual.audacityteam.org/manual/help/manual/man/preferences.html#reset
When you restart after resetting preferences you should see the Welcome screen.

I figured it out! For some reason I was trying to save the file in the folder called “Articulate”. When I changed that to the Music file on my computer it recorded just fine. Wonder why that was?

I’ve just done a File > Export of two stacked stereo tracks to MP3 (CBR, 192Kbps). It worked OK.