Unable to open target file for saving [SOLVED]

I have recored an LP and broke the recording into tracks by manually adding lables. I now wish to save separate tracks to my computer.
I have done this procedure successfully before, but now I cannot Save Multiple. I receive a message “Unable to open target file for saving”. The directory chosen has been newly created both in Finder and via Audacity. No joy. Any suggestions?
OS X Yosemite
Audacity 2.1.0

Audacity does that when you put certain punctuation marks in the filename. Dates are a problem. Today is 2015-09-05, not 9/5/15. Dashes and underscore are OK.


Audacity made by us has Export Multiple, but not Save Multiple.

Asterisks (*), question marks (?) and forward slashes (/) cannot be used in labels for Export Multiple on OS X, due to Audacity bugs. Other punctuation except colon should work, despite what Koz says, but punctuation in file names isn’t a good idea unless the files are only for your own computer.

If you don’t have permission to write to the created folder that would be another explanation. You can right-click or CTRL-click over the folder > Get Info to check the folder’s permissions.


Thanks very much Koz. I actually had 2 track names with a / in the name. The main problem was caused by the first one. Removed that and problem solved! Yay!

Thanks for the help Gale, problem now solved.