Unable to lose echo on voice recordings

I guess there MUST be a button, or two, somewhere in Audacity, that will get rid of this echo. I am trying out at the moment, as I need to do some audio tutorials done in the next couple of day, but the tests I am doing, sound like I am recording in a well tiled bathroom, with nothing to dampen the echo/reverb.

I have spent most of the morning, trying out other suggestions on the forum, but got knowhere. The mic - changed for another and same problem. Removed the mouse as I wondered if that was making any difference, having read a couple of articles about printer cables, but no difference.

Have used a crystal clear digital recording using a Sony dictaphone, that is great on its own speaker, but back in the bathroom when run through Audacity.

Maybe on of you guys can suggest what to do.

I’ve GOT to get this working for tomorrow morning. Without that annoying echo!


It always helps to say what version of Audacity you are using. Please see the pink panel at the top of the page.

Is this mic plugged into the mic port of your computer?

Choose the mic you are recording from as Audacity’s recording device in Device Toolbar.

Turn off Transport > Software Playthrough so you don’t hear a delayed echo of yourself while recording.

You probably want to turn off Windows Sound Enhancements for the mic.