Unable to install mod-script-pipe on 2.3.2 [SOLVED]

Hi there,

Lately, I have been trying to add the mod-script-pipe module, but failed.

In my latest attempt, I used the instruction by “Steve” on
but it resulted in the same error I got, when I used other methods:

In the end, the directory /etc/share/audacity/ does not include a module directory
(and of course audacity does not find it/show it on edit->preferences->modules).

During the installation I added the --with-mod-script-pipe to the …/configure command and when the script finished, it even read “mod-script-pipe enabled”.
Also in my build directory there was a lib-src/mod-script-pipe directory with a make file (and some other stuff) in it. I installed wxWidgets according to the tutorial and every step succeded without errors, so I’m pretty much out of ideas.

Just in case: I’m running Linux Mint 18 64bit with Cinneamon 3.0.7 and Kernel 4.4.0-21-generic

What am I missing? Please help!


You have to run “make” separately for mod-script-pipe, and then manually copy the mod-script-pipe binary into a location where Audacity can find it.

From the root of the source code:

mkdir build
cd build
../configure  --with-lib-preference="local system" --with-ffmpeg="system" --disable-dynamic-loading --with-mod-script-pipe
cd ./lib-src/mod-script-pipe

After the second “make” completes, copy (or move) mod-nyq-bench.so and mod-nyq-bench.so.0.0.0 from the hidden folder:

You then need to enable the module in Preferences: https://manual.audacityteam.org/man/modules_preferences.html
and then restart Audacity.

Thanks, steve!
Now it works!


Cool :sunglasses:
I’ll close this topic as “solved”.