unable to find audacity-2.2.2 rpm

The audacity website states that for linux release 2.2.2 is the latest stable release as 2.3.0 has known issues.
Searching the site then using rpmfind i haven’t been able to locate a download for fedora 29 x86_64.
can anyone point me to this rpm?
google only finds windows or mac versions.
spent over an hour searching with no result.

Is this any help? http://rpmfind.net/linux/rpm2html/search.php?query=audacity

Hi Steve,
only 2.1.3-10 and 2.3.0 for fc29 x68_64 available.
neither work on my system. symptoms the same.
the only time audacity (either version) is stable is if i do nothing.
the first time i click any option (apart from the menus) is becomes unstable whether i am recording or not.
Even just monitoring the source causes it to crash.
Hardware is asus p5q m/b with intel quad core cpu, 8gb ram, on-board audio.
Running fc29 xfce.

What do you mean by “any option” and “unstable”?

I’m guessing that you don’t build from source code. Is that correct?

Correct. I just used dnf to install 2.3.0 then when it failed i found 2.1.3 and removed 2.3.0 and installed 2.1.3
The failure is that the application freezes for a couple of seconds then closes (disappears from the screen).
The crash report shows that the application was “audacity killed by SIGABRT”
This is the consistent failure report.
As I said it doesn’t matter what I click on (apart from menu items) it crashes after a few seconds.
As 2.3.0 is not stable in linux I want to try the latest stable release which is 2.2.2 but cannot find it anywhere using google search or rpmfind for fedora 29.
the only 2.2.2 releases are for Mageia Cauldron on various platforms from rpmfind.
there are releases of audacity-freeworld 2.2.2 for fc26,27&28 but nothing for fc29.
As the Audacityteam website states release 2.2.2 is the latest stable release for linux i cannot fathom why it should be so difficult to locate.

That’s down to the distribution maintainers. We provide the source code for Audacity on Linux, and each Linux distribution is free to package any version of Audacity for their distro. Each distribution has their ideas about which applications to package, for example Ubuntu and Debian include Audacity in their main repository.

Audacity 2.1.3 “should” work, but it seems that Red Hat / Fedora has had this problem for a long time:

There are some reports that this problem is fixed by Audacity 2.3.0, but there is a bug that we know about with 2.3.0 which is that it will crash when previewing any “Real time preview” effects (such as “Bass and Treble”, WahWah, and any LV2 effects).

Audacity 2.3.1 is due to be released in January, so perhaps worth waiting until that becomes available, then take it from there.

Thanks Steve,
Still doesn’t answer the question of why i cannot locate release 2.2.2 for fc29.
Will have to wait till january for the 2.3.1 release.
Frustrating as a couple of years ago i was able to record half my vinyl collection without any problem.

out of curiosity i tried running 2.3.0 as root and after setting the proper hardware input and output devices i am able to run audacity without error recording vinyl LP sides.
don’t know what the differences are running as root but it works (for now).

I was in the same situation as you. I just built the rpm myself.

Feel free to grab them here:


The first link is the binary rpm that you can just install if you trust me; the second is the source rpm which you can examine and rebuild yourself.

The 2.3.0 version crashes whenever I tried to run a LADSPA plugin (not even a preview, just run it), so I don’t use it.

That is a known problem with 2.3.0, and is one of the reasons why 2.3.0 is NOT a release version for Linux. The bug has been fixed in 2.3.1 which is due for release later this month.

Right, that was my point :slight_smile: Just wanted to clarify that it occurs not only when previewing the effects but when applying them too.

I reported this issue (that they put out a buggy and non-released version) to both fedora and rpmfusion, by the way, but neither reacted in any way, sadly.