Unable to export mp3 files[SOLVED]

I’ve been struggling with this for hours and am getting nowhere (it should be noted, I’ve never used Audacity before). I have the project saved but when I go to “Export” and select mp3, I click “Save” and nothing happens. Nothing at all.
I’ve already searched online for solutions. I’ve installed LAME. I’ve checked the mp3 Export Library was as it should be (it was). I’ve uninstalled and re-installed both Audacity and LAME. Nothing has worked!
So, I’m hoping someone here might be able to shed some light on the situation as it’s getting really frustrating and I have no idea what else to do.
Many thanks.

What are you calling the files, the exact filename?

Promise not to laugh?
The audacity is file is “Do you wanna build a barricade 1” and I’m trying to save the mp3 as “Do You Wanna Build a Barricade?”

That should have worked. Where did you save it? Audacity likes to default to saving files in awkward places. Try saving to the Desktop.

I was trying to save it to “My Music.” Tried your suggestion; still nothing.

Does it export OK as WAV?

No. Sorry should have mentioned, it doesn’t export at all. I only said mp3 as that’s what I’m concerned with at the moment.

That will not work because “?” is a system-reserved character on Windows. Please see: Audacity Manual .

“Do you wanna build a barricade 1” will work (if you include the quotes they will be removed from the exported file name).


Okay, that worked. Don’t I feel like an idiot?
Thank you, Gale.

Well, standard file save dialogues in Windows have the same problem in other applications too if you put a “?” in the file name.