Unable to delete source file without closing Audacity

Windows 10 Pro 64-bit, Audacity 2.1.1 (and 2.0.6), .exe installer.

Typically I would open a few mpeg audio files in Audacity, edit them and export them as mp3s.

As I started exporting each one I would delete the source mpeg file.

Once exporting was finished I would close the file in Audacity but leave Audacity running.

Having updated to 2.1.1 and updated FFmpeg I found that I couldn’t delete the source mpegs in my usual way.

In fact, I have to close Audacity completely to be able to delete the source files.

I went back to Audacity 2.0.6 but the result was the same, I can only delete files which have been opened in Audacity by closing it down first.

If I open a .wav file I can delete it while it’s open in Audacity.

I can’t find anything I recognise in Preferences which might have changed in the update, I didn’t reset preferences initially anyway, though I have now.

I’d like to go back to how it was before, is there anything I can do?

Sorry this problem started in 2.0.6 and is either related to the FFmpeg 2.2.2 version that 2.0.6 upgraded to, or to changes we made to allow use of that later FFmpeg version.

As a workaround you can unlock the “handle” Audacity has open on the file, or unlock and delete the file to the Recycle Bin (both without exiting Audacity) using http://lockhunter.com/download.htm. You can use other similar unlock tools too, but beware many such other tools may try to install unwanted software on your computer.

Or, go back to 2.0.5 ( http://www.oldfoss.com/Audacity.html ) and the previous FFmpeg 0.6.2, which you can obtain from the link on http://manual.audacityteam.org/o/man/faq_installation_and_plug_ins.html#ffdown.


Thanks for the reply, much appreciated.

I tried Lockhunter and whilst it’s a very handy utility to have I think I’d find it a bit tedious to use it in this context. Handy for crashing Excel files for example though, so thank you for the pointer.

I’ve followed your other suggestion and gone back to 2.0.5.

Thanks again, Ian