Unable to append record

I’m using 2.3.0 on Windows 7. I was using 2.2.1 before, but I needed the punch and roll feature, so I downloaded the new version. Now, returning to a project which I’d already begun, I find that I’m unable to append-record. I’m in the process of recording a new track in addition to the tracks that have already been lain down, but now (and this certainly didn’t happen on this file in the previous version) when I press R or the record button the cursor always jumps to the very end of the song. I’m using this version ‘straight out of the box’ and haven’t made any changes to Preferences. I started a new file for testing purposes, and the behaviour is the same.

What could be happening here? I wouldn’t mind returning to the previous version, but is that possible?


Somewhere in there R and Shift-R got reversed. You can put it back in Preferences > Recording.

There were enormous complaints that R didn’t just append onto an existing track. “Why is it starting a new track. ‘Nobody’ wants that.”


Thanks Koz, but before I was able to continue on the same track (it’s narration, so I can always start in a gap between sentences - that’s why I installed the latest version to take advantage of Punch and Roll). I can see now that my previous post, in using the word ‘new’, was misleading - I’m sorry for that. What I meant was that the track I’m working on was in addition to the ones I’d already recorded, and I wanted to put all the narration on that track to avoid having dozens of new tracks being created as I recorded in chunks of narration.

In version 2.2, the default was that the recording would begin at the cursor in the active track, but that doesn’t seem to be available any more - the choice appears to be either a) create a new track each time, b) start at the very end of the project. Is there a download page somewhere where I can revert to the previous version? I need to get this project finished today, and maybe going back to 2.2.* would be quicker than trying to get to the bottom of why the new version is behaving as it is. (I haven’t seen anybody else raising this problem, which makes me think that it only happens to me!)

I think it’s this one.



Are you sure you’re using Punch and Roll? Punch and Roll backs up from the current cursor position the number of seconds set in preferences. Then it plays forward for cuing and drops into record. It does a very rapid cross-fade like a video editor instead of switching right into record to avoid pops or clicks at the edit point.



Thanks again, Koz. I didn’t get very far with Punch and Roll, because each time I press the command I get the message ‘please select a stereo track’. Now, my narration is on a mono track, but I get the same error message if the active track is a stereo one. So (because of time pressures) I gave up on Punch and Roll for now and have tried getting used to Shift-R recording. The problem with that is that the new track that’s created is always a stereo one, and it puts my mono microphone feed into one track of the stereo, creating a mismatch in sound (e.g. panning) compared to the existing material. I can’t find a preference option to ensure that new tracks using this feature can be forced to be mono ones.

I’m afraid those are much older versions, intended for XP, 2000 etc. Maybe System Restore is what I need to use, or maybe I’ll try and convert what I’ve already got in mono into a stereo track to match the newer material.

That’s because you are trying to Punch&Roll Record into a Mono track when you have you record settings set to 2 channel stereo

It’s not a preference, its a setting in the Device Toolbar:

Set the recording channels 1 Mono - and then you will be able to Punch&Roll in a mono track


Many thanks. Much appreciated.

In the meantime, Audacity suddenly began working as before (appending on the same track) without my having done anything. So all is good, but strange. I’ll have a go at Punch and Roll when I get a chance; however, I can’t at the moment, as the program has just been ‘paused’ by my ransomware detector, which names 16 ‘affected files’ (*.au, *.aup, *.cfg and *db files), so I’ll have to decide whether to whitelist or to block!