UGH,.. Lost,...

I currently dislike computer recording,. :smiling_imp: (I know, I know,… get with the times…) Well, I am trying to.

Put me in a room with an SSL or a NeveV, a couple of Studer 24s, and a wall of outboard processing and I would feel right at home. :smiley: Unfortunately, I don’t think that kind of room even exists anymore, :cry: … so to say I am a little outdated is a gross understatement. :unamused:

What I am trying to do, and seem to be having a rather difficult time accomplishing is the following: :confused:

Using windows xp with pack 3. I wish to record what I hear out of my laptop speakers. Having read the manual for Audacity, I learned that using the internal sound card (a sigma tel ) would prove impossible because it would NOT allow me to select “sigma tel” in the input device drop down window of Audacity.

So I purchased a little Behringer usb 1204 to utilize it’s sound card. All drivers are installed. USB is connected, and the Behringer shows up on both the input device drop down menu and the output device drop down menu.

So, what is happening: I seem to be able to get audio TO the 1204 ( I still can’t figure out exactly what configuration is allowing this as I can find no consistencies in set up), BUT I don’t seem to be able to get audio either back to Audacity ( there is no signal level in the metering) and I can’t hear anything coming out of my laptop speakers.

Again, the goal is to hear a sound being played on the internet, and record it, through the 1204, and hear it on the laptop speakers.

Question: Does anyone think they know WHAT I am doing wrong? I have tried many different setting combinations (Audacity input, Audacity output, laptop sound playback, laptop sound recording) and nothing seems to work.

Any help is greatly appreciated, Thanks,… :mrgreen:

The ability to record what is playing on the computer using the on-board sound card depends on the sound card and the sound card drivers.

If your computer sound card has a recording input option called “Stereo Mix” (may be called “Mix”), then you can use that to record what is playing on your computer.

On XP,

  • Start menu > (Settings) > Control Panel > Sounds, Speech and Audio Devices > Sounds and Audio devices.
    (You may also be able to open the same scree if you right-click over the speaker icon in the System Tray and select “Adjust Audio Properties”).
  • Click on the Audio tab, and in the “Sound Recording” panel, select Sigma Tel as the “Default device” from the drop-down list, then click “Volume”
    You should then see a “mixer panel”
    Look to see if there is an option called “Stereo Mix” or “Mix” or something similar. If there is no such option…
  • Click on the “Options” menu and select “Properties”. Ensure that the Sigma Tel is selected in the Mixer Device panel.
    You should now see a list of recording inputs. If there is an option for “Stereo Mix” or “Mix”, put a tick in the box next to it.

Does your Sigma Tel device have a “Stereo Mix” (or “Mix”) option?
If it does, then when it is enabled you should be able to select it as the recording input in the Device Toolbar. (The output playback device should also be set to play through the front speakers of the Sigma Tel sound card).

That was exactly the issue. The Sigma Tel does NOT have the “stereo mix” option.

Which is why I purchased the 1204 usb console. SO that I may utilize it’s sound card and select it as the input to Audacity.

Repeat the process, but with the USB mixer selected as the “Default device” from the drop-down list in the “Sound Recording” panel.
Does that have a “Stereo Mix” option?

To be specific: If you mean the “sounds and audio device properties” window, under the tab labeled “Audio”, the drop down menu for “sound recording” does NOT have a “stereo mix” option. It does offer a choice of Sigma Tel, Behringer USB Audio device, USB Audio Device, and some other non-relevant choices.

Just noticed a potentially related issue: When I select the usb sound card (Behringer usb audio device) as the default device, Audacity automatically lowers the “input volume slider” to 0. When I raise the volume of this slider the “mute” box gets checked under the “device volume” area of the “volume” tab in the “sound and audio device properties” window. … When I uncheck the mute box, the slider goes to 0 and when I move the slider back up, the mute box gets checked. This must be affecting all this in some way, no?

To be fair, you did pick one of the more convoluted jobs in computer land. Many of the modern Windows laptop computers have this function locked out and all the modern Macs can’t do this at all without additional software or hardware. It’s not a guaranteed computer service like lighting up the screen or making the mouse go left and right. It also tends to make conferencing and communications through your machine more difficult, so it’s got to go.

This is more normal.

That’s a Peavey mixer in the middle and a laptop (closed) on the right to record the performance. Dead simple, although there are a few computerisms that creep in there as well.

I’m surprised that Windows XP will not let you self-record. Typically Vista and Win7 hide these tools sometimes permanently, but XP was usually pretty liberal about it.


You are doing the rough equivalent of multi-track production on a Studer – with no Neve. The show is on tape and you need to put the final production – on the same tape. You are in the process of either banging on the patch bay or crawling behind the Studer with jumper cables to put the routing together. The “patch bay” in this case would have been Stereo-Mix. the ability to route the speaker system back into the recording system. Failing that, you’d be pulling the speaker feed out of the computer and then putting it back in. You can do that very easily with a patch cord if your computer has Stereo Line-Out and Stereo Line-in. That’s Blue and Green sockets for those counting.

Most PC laptops tend to be missing the blue socket.

So you lose on Spots Call.®

You picked a USB mixer and I would be awfully tempted to try a dead simple recording, say from a microphone, and playback before doing anything convoluted. Assuming that’s where you are, then it may be valuable to close Audacity and do a recording in Windows Sound Recorder.

– Windows Sound Recorder
– Start > Programs > Accessories > Entertainment

That means you also need to get the computer routing and drivers correct in the Control Panels. If you can’t get that to work then keep working backwards. Can you hear a microphone in headphones plugged into the mixer, etc. Standard, simple troubleshooting.

Post back where you got stuck.


Thanks very much for your reply.

I can’t believe this would be considered “convoluted”. All I really want to do is have, as Audacity’s input, what I hear in the headphones. That source being whatever sound I “hear” off the internet. Is this really such a big deal?

As described above, I have already given up on the internal sound card, but I was told that I should be able to perform this rather simple task if I purchased a “different” sound card. Rather than spend the money on just a sound card, I decided to go ahead and get a little usb console with a sound card. The problem is I can’t get ANY input to Audacity except from pre-existing audio files (mp3 and the like) or the mic input of the laptop.

Should the Behringer usb audio device have an option of “stereo mix”?

I really don’t want to take a mini stereo cable from the headphone output, to the console and then out of the console and into the mic input.

I suppose the simplest solution would have been to just purchase another laptop to use as the source. Run it to the console, and then run the output of the console into the 2nd computer to record with Audacity. I can’t believe these are the only solutions. How do I get the audacity input drop down menu to give me the option of “stereo mix”?

Is this really such a big deal?

Yes, it is. As above, you bought a business computer and corporations tend not to need to record a cat flushing the toilet on YouTube.

to perform this rather simple task

Which it’s not. You really need to stop thinking about it that way. Recursive re-entry is a special service. If you do it wrong, your computer can go into screaming feedback – and may anyway.

The problem is I can’t get ANY input to Audacity

Stop using Audacity. Close it. See if you can make a recording using the Windows Sound Recorder and a microphone on the mixer.


Do you mean this ?

That does not record computer playback. Stereo mix is a feature that self records audio that is playing through the device. Mixers don’t normally do that.

Have you got correct drivers for the built-in computer sound card? Most XP machines had stereo mix if you used correct drivers. See here .

If you don’t want to record by running a cable off the audio output of the computer, then you are into using other software that specifically adds ability to record computer playback, even if the sound device doesn’t offer it. Audacity does not do that, but try .