Ubuntu Crashes, AUP file now lost

I recently downloaded Ubuntu 13.04, and have been having problems with it since day one. Half of the time I click the “search computer and online sources button” the whole thing just freezes and I’m forced to restart. I also have the same problem occassionally when I open Firefox, and if I am running a program like Audacity or Open Shot, these programs will typically crash after a few minutes. I had a problem with Windows freezing before I removed it from my computer, so I don’t think Ubuntu is entirely to blame.

Anyways, I thought I was dilligent enough just to save every few minutes. This time however, I had Audacity 2.0.3 opened (file saved), and attempted to open Firefox. The system freezes and I’m forced to restart as usual. When I go to open the AUP file now, all I get is “File may be invalid or corrupted”. The same thing happened with another file that was open when the computer froze about a week ago. Is there any backup file that might contain my work, or is there any way to recover this particular file? I have an older version of the file backed up elsewhere, but I really want to try to recover this file instead of throwing away more hours of my life. If anyone has any suggestions for fixing these constant crashes, they would be greatly appreciated also. I’m super fed up at this point, and can’t wait till I buy a new computer so I can beat the hell out of this one, Office Space style…

What are your computer specifications? Ubuntu is a heavy version of Linux these days. It won’t run properly on 1 GHz and 512 MB of RAM :wink:

You need to fix the computer or try Lubuntu ( https://help.ubuntu.com/community/Lubuntu ) which needs less resources. How much RAM have you got? RAM is very cheap to buy these days.

If the project has unsaved changes the current state of that project is stored in an autosave file in Audacity’s folder for application data. Please see here for details http://manual.audacityteam.org/o/man/audacity_projects.html#autosave . However if Audacity does not offer to recover the project when you restart the program that probably means there is no autosave file. In that case the last saved AUP is all you have. Please attach the AUP and we’ll take a look at it. Please see here for how to attach files: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1 .



Gale

Thanks for the reply. I have 2 GiBs of RAM, 2.2 GHz speed. Unfortunately, Ubuntu is way more technical than I expected, so I have no clue how to daignose and fix my computer. This is really a nightmare though, it feels as if I’m spending more time rebooting my pc than I am actually using it…there is actually an internal error message that pops up occassionally, and a system issue message. I will catch the next one I see, and if it doesn’t shut down before then, I’ll post it here…

I did find the au files for the project, and have been spending the last few hours puzzle piecing them together. The original aup is completely empty, as if the information just mysteriously vanished.

I have another concern now as well. I had originally backed up the aup via Dropbox, but when I tried to download it today, it would not work, saying that the needed files are missing. I also can’t download the exported mp3 I had backed up, because every single time I try my computer freezes. Is there a proper way to backup AUP files that I missed? I never included the data files, so maybe thats it…

Anyways, I’m going to explore the temporary files and autosave directories, that way I don’t have to spend the rest of the night piecing this project back together. I’m terrified the same isssue is going to occur again though. I’ve typically learned how to protect my work against all these unexpected technical issues, but this is kicking my butt…

How about looking at the crash dump:
https://wiki.ubuntu.com/Kernel/CrashdumpRecipe

or asking on the Ubuntu Forums?

Most crash problems are driver problems or occasionally hardware problems. The answer could be as simple as for example attaching a faulty USB external drive to the computer, a faulty USB modem or one with incorrect drivers, or having inappropriate video drivers or a faulty video card. It could even be a faulty motherboard.

This is not an Audacity bug. If you are using Ubuntu, you should ask in the Ubuntu Forums.

Are you looking at the AUP in a text editor?

If you successfully saved the project before as you said, there will be no AU files in Audacity’s temporary folder. All the data will be stored in the project’s _data folder.

If you don’t have a usable AUP file and this is a recording that you never edited, you can follow the steps here to time sort the AU files in the _data folder for the project.

If the project was heavily edited, it’s best to write it off. In that case there is no way to piece it together without an AUP or autosave file.

Please see http://manual.audacityteam.org/o/man/audacity_projects.html . The AUP file is just a text file that says how to stitch the AU files in the project’s _data folder together. The _data folder has to be available to Audacity in the same folder that the AUP file is in.

To make a backup of a project, File > Save Project As… and save to a different name. A name that tells you the date and time of the backup is good, such as my_project_backup_11aug2013_0956. This saves a new AUP with a new _data folder.

Make export backups as WAV, not lossy formats like MP3.


Gale

Thanks for the information. I’m pretty confused because the same thing happened today (AUP file mysteriously corrupted or made invalid), except the system did not crash at any point while Audacity was opened. Also, I haven’t noticed any other saved files for other programs having any issue with data loss.

Yeah the only thing I can do is Save As to another file…i did that for this last file, but I guess I’m going to have to do it more frequently. I really don’t have too much to go on this one project, but after this experience, I’m not really sure if I want to keep using the program afterwards. Disappearing information is not a technical issue I want to risk with bigger projects…I know its an issue with Ubuntu crashing, but Audacity seems to be reacting worse than any other program I’m using…

You mean you closed the project apparently normally, then the AUP file would not reopen? What error message was given when you tried to open it?

I would tend to export WAV files regularly if you think the AUP files are not saving correctly. But we cannot comment on that without seeing the file and knowing the error message.


Gale

Yeah thats how it happened. I don’t get an error message ever (if it does not recover). It just states that the file is either corrupt or invalid, and when I check, there is 0 bytes of information in the file. I never get a warning or anything, but I know it happens everytime Ubuntu crashes while Audacity is open. This time though, I really don’t know what happened, Audacity was closed normally about 30 seconds before I tried to open Firefox and Ubuntu crashed.

I’ve resorted to Saving As and exporting every 15 minutes or so to prevent the issue. This time, immediately after I saved my third Save As file, the program froze and I was forced to restart it. The older file (File 2) showed up after restoration…when I checked, there was no AUP file for File 3. The weird thing is that there was a _data folder for File 3 that had been created normally. Bizarre no?

No that is not bizarre if Ubuntu crashes while saving the project because the AUP file is saved last of all, after saving the _data folder.


Gale

Well, I’m spending some time in the Ubuntu forums to see if I can get some help, since this might not even be an Audacity issue. Once I get Ubuntu running smoothly, and my PC stabilized, if I still have issues with Audacity I’ll revisit this post. Thanks for the help!

If the machine freezes or crashes, it is not an Audacity issue.


Gale