Ubuntu: 20.04.2 Audacity 2.3.3 and 3.0.3 export silence

Ubuntu 20.04.2 LTS, using the Ubuntu supplied Audacity 2.3.3. I start a project with a 2 hour MP3 (concert), add a label track, put labels in there over the individual songs in the concert, and do an Export Multiple so I get a file for each song. This is a workflow I’ve used for years (just not on this PC/OS).

The exported files are of the correct length, but have silence (flat waveform). I’ve tried Export Multiple as various WAV formats and OGG, and get the same result. I finally tried to export the entire project as a WAV, and get the same result (file with the correct length, but no sound). Export seems very broken.

I downloaded the 3.0.3 AppImage, and have the same result.

Switching to 3.0.3 on Windows 10 on the same (dual-boot) machine, everything works fine, and that’s my workaround, but I’m trying to get away from Window$.

This worked fine on this PC when I had Ubuntu 18.04 on it (as I recall).

I thought it may be some sort of library problem, but I don’t see anything evil in Show Log:

12:43:22: Audacity 2.3.3
12:43:22: Retrieving FFmpeg library version numbers:
12:43:22: AVCodec version 0x3a3664 - 58.54.100 (built against 0x3a3664 - 58.54.100)
12:43:22: AVFormat version 0x3a1d64 - 58.29.100 (built against 0x3a1d64 - 58.29.100)
12:43:22: AVUtil version 0x381f64 - 56.31.100 (built against 0x381f64 - 56.31.100)

I can run Audacity from the command line in a terminal and see stdout/stderr (attached file: audacity.log) Nothing evil there that I can tell?

I’ve done Googling and forum searching, and every posting I can see about something like this was an exported file that actually had data in the waveform, but didn’t play to the audio, so those haven’t been helpful.

Suggestions on how to track this down?

don’t see anything in the log:
audacity.log (17.4 KB)

Windows guy here equally befuddled. So you have the same issue whether you use Export or Export Multiple. And it doesn’t seem to be related to the presence of a label track. Is it only this 2-hour mp3 file you are having problems with? What happens with a shorter mp3 file.

Good thinking. With 2.3.3, I can import a 2 minute MP3, export the whole thing as either a 16-bit or 24-bit wave successfully.

Went back to the big file, reran the workflow, and everything is correct.

I have no idea of what I did different between yesterday or today, or what changed. I do know I had multiple failures yesterday, so whatever I was doing wrong, I was being consistent about it.

Glad to hear all is working :smiley: - at least for now.