Ubuntu 18.04 - No devices

i have the same problem with ubuntu 18.04 fresh installed and audacity 2.2.2

please help me

getent group audio

did not work for me :frowning:

thank you

Screenshot from 2018-11-04 18-58-30.png
Screenshot from 2018-11-04 18-58-07.png

Does any audio work on this machine?

with windows10 everything works

with ubuntu everything works exept recording. i have no recording device in my soundoptions.
after i deinstalled skype in ubuntu i can now see pulse device in audacity, but i can not record from mic. either there is no sound or there is the sound that is playing in background e.g from the browser.

Did Skype work when you had it installed?
What sort of mic do you have and how is it connected to the computer?

skype did not work in ubuntu, but it worked with windows10. also audacity worked in windows10.

i have an acer aspire nitro V 17 VN7- 792G laptop with build in soundcard.

What was the problem?

the problem is i have a realtek ALC255 soundcard.

either i have white noise
or i have nothing

maybe someone knows a solution for my problem.

OK, so this appears to be the problem: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1523100
(also reported here: https://bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/1789154)

Unfortunately there does not appear to be a fix yet.

You could work around the problem by buying a USB audio interface. The cheapest ones tend to suffer from poor sound quality when recording (as do most built-in sound cards), but they only cost a few dollars and provide basic functionality. Better quality devices are available at higher cost.