TT play-through audio disables speakers on Mac

Am running 2.0.3 on my Mac 10.7.5. Plug in my TDK Belt Drive TT to USB port and launch Audacity. Run through all steps in the Wiki, including enabling Play-through. Can see the output levels going up and down so sound is clearly coming into my Mac. No Audio output though even though I have gone into Mac settings and adjusted the MIDI settings as referenced in the Wiki. Still no output.

Even more confusing, my internal speakers are now completely disabled. Head phone jack works for iTunes music (not vinyl at any point though). Once I unplug the TT from the USB, iTunes audio through internal speakers will again work.

The frustrating part is that I HAVE been able to play both TT and MP3 audio through the internal speakers in the past. Both would/could play at the same time if I wanted. It just stopped working at some point and now I can’t get the TT to pass-through the internal speakers at all. If I plug the USB TT back in and turn it on, it will disable internal speakers & I get no audio whatsoever.

Is there some setting I am missing somewhere inside MacOS? Odd to me that it has worked in the past but now doesn’t.

Help please!

In Audio MIDI Setup, set the output to Built-in Audio, 44100 Hz, 16-bit.

In Audacity, set the output device in Device Toolbar to Built-in Audio.

Modern Macs don’t have built-in playthrough. If Software Playthrough or Hardware Playthrough in Audacity’s Recording Preferences don’t work, try Line In .


Gale