Trying to help a friend


Newcomer here, and newbie Audacity user. I used Audacity to record an EP recently, my style is as guerrilla as it comes so it worked brilliantly for what I needed (no post processing, no punch-ins, just recording track by track all the way to the end of each song and then a rough level mix). For future releases the production side will be a bit more professional, but this release was intended to be raw and my resources were limited and I was anxious to get it done. I used a laptop with Windows 7, Audacity, Mackie Blackjack, Mackie HR624mkII monitors, some karaoke mic my mom has, and my instruments (since the Blackjack only has 2 ins, for drums I miced up the kit with some drum mics and ran those into a mixer, then from that mixer into the Blackjack). The result can be heard at the following link (DISCLAIMER: It’s black metal, by most people’s standards the audio quality sucks and I am aware, but I am proud of it and just want to share what I used this program for with the program’s community):

Ok, introduction is out of the way so here’s my issue. My friend is trying to set up an interface to record, here is what he has:

-Windows 7 comp. w/ Audacity (not sure of version, probably the newest)
-Focusrite Scarlett 2i2 interface connected to comp. via USB
-Acoustic-Electric guitar running straight into Input 1 on the interface via cable
-Headphones plugged into the headphone jack on the interface

Audio is playing through the headphones, drivers are installed on the computer and enabled for recording and playback in Audio Settings in the Control Panel, in Audacity for input and output devices I have the interface selected. The issue here is that when we hit record, the program will show levels momentarily but the program seems to freak out, the time marker thing (don’t know what it’s called but it moves across the screen with the waveform left behind it) starts blinking red and glitching out and not moving across the screen. Then either the program will shut down or we’ll be left with a half second long garble of noise. Tried again using Reaper, thinking that maybe Audacity isn’t compatible with the interface but alas, in Reaper when we hit record absolutely nothing happens (track is record enabled, and I’ve selected the interface for input/output just as with Audacity).

Since we are having these issues in two different programs I’m hoping that maybe there is just a system setting somewhere in his OS that is causing these issues, but I really have no clue. With my Blackjack and laptop I had no such difficulties, pretty much plug and play after installing the drivers and enabling them. Anybody have any ideas?

I’m not on Windows, but here is a piece on stuck and stuttering cursors from the FAQ.

Basically, you can have bad driver software or the computer is too locked down to record live audio. It’s not unusual for a computer normal in all other respects to fail live audio (or video). Recording live audio with split second timing and critical file management is very different than recalculating a large interlinked spreadsheet or blurring a Photoshop picture.


Got it figured out, the drivers that he had were installed from a disc and not up to date. Got the updated drivers from their website and it all works now, thanks for the tips.