Trouble with 'metallic' sounding interference

Hi all,

I’m looking for some help with a problem I am having with ripping vinyl to my computer. I have been doing this for the past year with no problems however after a recent house move and an upgrade to Windows 7 I’m encountering some irritating interference on recording. I can’t hear it all the time and it only seems to affect mid range and bass frequencies. The best way I can describe it is a kind of metallic scraping or clanging.

The sound from my record deck is perfect. The interference only occurs after the sound has been processed by the computer.

I’ve tried changing the soundcard to an external one and the interference is still there. The external card was a cheap hong kong import but I hope this shouldn’t matter. I tried shielding my graphics card too, but no joy. I am using pretty standard cables and don’t want to splash out on fancy ones unless I’m sure this is the problem.

Prob best to let you hear for yourself, the first 30 secs or so of this record are just 4/4 bass drums and give the best example of the interference.

This is my recording - http://www.mediafire.com/?4jznac5slhlj435

This is how it should sound - http://www.mediafire.com/?eq9i10y8myj0e91

Any ideas on what is wrong much appreciated.

Cheers.
Steve

IMO the “interference” is distortion caused by the signal being too high (too loud)…
Overload distortion and clipping on A2 (need to turn down the gain).png
There are hardware gain controls : an actual physical knob on your turntable.
And a software gain control : computer settings on your “USB Audio Codec” (“levels” slider).

Reduce the gain setting on the USB audio codec if this distortion did not occur with this hardware before the upgrade to windows 7.
You’ll need to cut the gain by about 10db until the waveform does not quite reach the extreme +/-1 values, ( a.k.a. 0db), i.e. no clipping.

see … http://wiki.audacityteam.org/index.php?title=USB_turntables#Recordings_too_loud_or_soft

Thanks for reply. I gave it a shot and i’m pretty sure it’s not the gain setting. It’s there with the gain turned down too. Any other help welcome.

Thanks.

A2 is severely clipped, look at the flattened peaks and troughs …
A2 is severely clipped.png
Something is turned up too high .

Yeah I agree there. It is a loud recording but I have recorded about 250 LPs at the same level under XP and they display none of the metallic interference I’m getting now. With the gain turned down on the turntable output and at the control panel for the soundcard I’m still getting the metallic noises.

I’ve just re-read your question,
I mistakenly thought you were using one of those USB turntables.
Sorry :blush: .

Make sure the output from your turntable is “line-in” and is plugged into the “line -in” socket on the sound card / computer.

You may have to select the “line-in“ option from within the software if your sound card only has one input socket.

If you feed a “line in” level signal into a “mic” socket on the sound card/computer the “line in” signal is too high and the sound is distorted as a result.

No problem. Just to clarify, Audacity is set to line in and I have my record deck running into a gemini mixer then out its booth output and into the line in port of a soundblaster audigy on my PC. I’ve spent the past hour unplugging everything electrical I can find but this has had no effect. Is it perhaps possible that that the electicity supply itself is causing interference?

Read Trebor’s post again and look at the waveform. Something is clipping somewhere. It is not interference. You were fine on XP but are having problems on Vista - that’s the change that triggered the problem. Look closely at your Vista sound control panel settings. One of the Windows elves can help you with the fine points of that.

– Bill

OK, I downloaded the two samples, and there is something very interesting about the distorted sample.
compare.png
First, one file is inverted compared to the other - I’ve inverted the “good” one to make comparison easier. I also lined them up time-wise.

I have View > Show Clipping turned on, but note that there are no red lines in the Audacity waveform display to indicate clipping. This says that the clipping is happening before the sound gets to Audacity.

This is not interference. Stop wasting your time unplugging things and thinking about shielding your video card. Find the source of the clipping.

– Bill

That makes sense. So my problem is somewhere between the sound entering the souncard and getting to audacity. Something I’ve noticed which would confirm this is that no matter what recording software I use I’m getting the same distortion. I’ll have a good look at the soundcard settings panel tonight. Thanks.

Been mucking around with the soundcard settings for a while now but nothing seems to fix it. I’ve tried turning levels down in the recording devices menu (access by rightclicking the speaker icon in the tray at the bottom right) and changing as many settings as I can find but with no joy yet. Any help here much appreciated.

Something I’ve noticed is that this problem seems quite common:
Listen to these clips.

http://www.youtube.com/watch?v=16nkgAXUiyw
http://www.youtube.com/watch?v=FfezbkDpujs&feature=related


It’s faint, but the distortion is definitely there.

Hmmm…

Can you make it worse?

Is there any setting that can create complete garbage intentionally? I bring that up because we’re suffering from a very odd problem with some of our sound cards. The control panel lights go on and off and the sliders go up and down and none of them affect the sound card at all. Zero. Zip.

We, too, get overloading distortion, but have learned to live with it by preparing recordings quieter than normal. I’m working with another department of the company to try and resolve this. We’re doing this on linux machines, but I think we both have driver issues.

Koz

Have you tried turning down the “booth” output of your mixer while watching the input level meters either in Audacity or in your system sound control panel? If you can get the Audacity meters to peak at around -6 dB you might have success. It is possible that the input to the sound card is being overloaded, and no messing with the input level sliders can fix that.

This does not address the underlying problem, but might at least allow you to continue your recording project until we can really sort things out.

– Bill

I’ve tried altering the booth output so I peak at -6 dB and even lower at -24dB but I’m still getting the same distortion. I took the mixer out the loop completely and used the tape outs of my amp but still the same. I am going to try and get ahold of a better quality sound card tonight. I’ll keep you posted.

The youtube rip of the Robert Hood vinyl is clipped in places (red) …


Not as bad as yours though.

Trebor - how do you get that view of the waveform that shows the clipping? Can’t find it in audacity.

The multi-colour view is not on Audacity : I coloured a screen-grab of the Audacity display using GIMP, (using “bucket fill”).

Audacity does have a “Find Clipping” option, (in the “Analyse” menu), but it won’t mark points which are clipped on your example as the clipping there has occurred before the signal got to Audacity: your flattened peaks and troughs are just short of +/-1, if they had been clipped by Audacity they would be +/-1.

Thanks.

Managed to get ahold of an m audio 24/96 card today and it has fixed the issue. Plus the sound quality is far superior to the audigy so I reckon I will be buying one. I think kozikowski is right in that it is a driver issue. Creative should look into this, I will be posting them a mail about it. Thanks for all the advice. Much appreciated.