Trouble setting up PC, choices are different

I am having trouble following the manual that came with my 2.0.3 unit, trying to load onto laptop with Windows 7 64. In the manual, after opening control panel, then Sounds, and selecting the Recording tab, it says I should select Microphone USB Audio CODEC as my default. Don’t have it. My possible choices are Internal Mic IDT High Definition CODEC, Microphone Line-in IDT Hi def CODEC, Rec. Playback IDT Hi def CODEC, and Line USB Audio Codec. Then, I should go to Playback and select Speakers SigmaTel C-Major Audio. Again, not a choice I have. Mine are Speakers/Headphones IDT Hi def audio CODEC, or Speakers USB Audio CODEC. I guess I should get those default settings sorted before moving on to how all the choices under Preferences are different as well. Has anyone else run into this, and do you know which of those I should select, or how to find the correct choice, or??
Sorry for what is probably basic question. I miss the days when I could just scotch tape a nickel on the tonearm and get on with it. Thanks for your patience.

If you are trying to record from a USB tape deck or USB turntable, I suggest you follow our Manual, in case there are inaccuracies in what you’re reading now. See: .

That step is redundant as far as Audacity is concerned, because you have to select the correct USB Audio CODEC as recording device in Audacity in any case.

Try disconnecting the USB device. If the “Line USB Audio CODEC” disappears, then the “Line USB Audio CODEC” is the device you want to record from.

Then you want to do a step they did not tell you. Right-click over the “Line USB Audio CODEC”, choose Properties, click “Advanced” (at the top) then make sure “Default Format” is set to a stereo choice.

If the “Line USB Audio CODEC” is not the USB device you are trying to record from, then

  • Switch off and unplug the recording device at the USB connection and at the mains
  • Plug the recording device into a spare USB port (not a USB hub that has other USB devices connected to it), and switch it on
  • Wait a few minutes then completely shut down the computer and restart it.

They are telling you to choose whatever the built-in sound device of the computer is. In your case, the built-in device is “Speakers/Headphones IDT Hi def audio CODEC”. You will want to select that playback device in Audacity Device Toolbar, but you don’t need set the speakers as default in Windows unless you want to play sounds in Windows while the USB device is connected. When you disconnect the USB recording device, the speakers will automatically become the default Windows playback device.

If you do want to make the speakers default Windows device now, then as well as selecting the device you have to press “Set Default” at the bottom.

Then restart Audacity if it’s already running. In Device Toolbar, as well as setting the playback device to “Speakers/Headphones IDT Hi def audio CODEC”, set the recording device to the "“Line USB Audio CODEC” (or to whatever the USB recording device is called).


Thanks for your help, Gail. I was able to do the first bits, but when I open Audacity it all goes wrong again. I think that is because the manual that came with my 2.0.3 shows the screens from 1.2.6 so I don’t, for starters, have an Audio I/O tab. Pressing blindly on, if I open Preferences and click on devices from the list on the left, I am able to select USB Audio CODEC under Recording, Device, and 2 (Stereo) under Recording, Channels, and have no boxes at the bottom to tick or untick. The first step, however, selecting your internal sound card under Playback, Device, presents a minor problem. I suspect it is either Microsoft Sound Mapper-output, or Speakers/Headphones (IDT High…, and not Speakers (USB Audio CODEC) or Independent (RTC) Headphones, but not sure which. Any tips?

Then, under the Quality tab, Real-time sample rate converter, I have no Fast Sinc Interpolation choice, only Low Quality (Fastest), Medium Quality, High Quality, and Best Quality (Slowest). Under High-quality sample rate converter I have no High-quality Sinc Interpolation, only the same 4 choices as above.

What would really have been helpful, though, is if a manual for the 2.0.3 version I purchased, rather than for 1.2.6, had been included. Once I can get this baby launched I should be OK, or least have more challenging questions. Again, I appreciate your patience, Thanks.

When you buy a hardware device we have no control over the version of Audacity (or the version of the Audacity Manual) supplied. The company that makes the device just download Audacity and any documentation - or write their own documentation - often with little clue what they are doing.

If you insist on reading the wrong manual then we can’t help you. You need to take your computer mouse and click this link: then you can read the correct documentation.

Also please tell us what exactly this device is - make and model number.

You can make the correct Audacity device selection in either Device Toolbar or Devices Preferences. Set the playback device to “Speakers/Headphones IDT Hi def audio CODEC”, and set the recording device to the “Line USB Audio CODEC” (or to whatever the USB recording device is called).


The device I am setting up is an audio-technica AT-LP60-USB, and the CD included is for the 2.0.3 version. Sorry I missed the link to the manual in your first response, I’ve downloaded 2.0.5 and will see how that works out. Thanks for your help, Gail.

OK thanks for telling me it was an audio-technica AT-LP60-USB turntable.

I’ll check with Audio Technica to make sure they include the correct manual. If they provided you with an installer of 2.0.3 then the correct 2.0.3 Manual should already have been included at Help > Manual (in web browser) in the Audacity program.