Trimmed and editted Mp3 is silent

I’m a total noob, so speak to me like a child that I may understand.

I’m running 2.0.6 on Linux Mint 17. I specifically just switched over to Linux a few days ago so as to run relatively good video-editing software. To replace the pathway I used to acquire and import Mp3 sound files to the old (piece of crap) editing software I was using, I downloaded Audacity today, so as to be able to import to Openshot video software.

My problem is this;…I converted a youtube video to an Mp3 file using a free conversion website I have used before. I then imported that Mp3 file into Audacity to edit it for use in a video project. It imported successfully, and I thought I had trimmed and edited the clip successfully. I then exported it as an Mp3 directly (without use of any other lossless intermediary conversion step such as a WAV file) to my “Music” directory on my home page, where I also had the original unmodified Mp3 file I first downloaded from the net. But while the originally downloaded Mp3 will play, the one I created on Audacity is totally silent. The player appears to be playing it (the cursor moves along the timeline), but no sound. The player is Faenza Studios video something or other that came with the basic Mint 17 OS package.

Any suggestions?

What happens when you pull the music file back into Audacity?

Haven’t tried that. Just left the modified file on the board and have not closed Audacity yet.

Hmmmm,…ok,…tried that and there is nothing there,…no waveform appears.

Also tried the WAV file I produced of the same modified original file,…it too came up bupkiss.

So I somehow did not preserve my editted version correctly before I attempted to export it, or what?

No waveform appears, but is the “show” the right length? Do you have bupkiss for three minutes if you started with a three minute show? Open the show in Audacity again and press Control-F for a full show on the timeline and read the time.

There are seriously magic reasons to produce a silent show and depending on your responses we will probably figure it all out.


Correct, both in Audacity and the player I attempt to play the new file in,…it runs for the entire 15.75 seconds, but there’s nothing there.

That’s a mistake because you have needlessly lost quality by encoding the audio to MP3. When you export to MP3 you’ll have lost quality twice.

What you want to do is download the video (use your favourite search engine), then if FFmpeg support is enabled in Audacity, drag the video into Audacity and let it extract the audio to PCM so that it has no loss of quality. By the way did you really mean Audacity 2.0.6? It has not been released yet.

Alternatively convert the video to WAV using FFmpeg from a terminal:

ffmpeg -i youtube_video.flv audio.wav

In any case, why do we need the inquest about what you did? You still have the converted MP3 and you can go one better by working on a WAV of the video (assuming it has not been taken down).

Note that Audacity tracks with the Mute button down are not exported.