Tracks don't fit automatically after opening

Using Audacity 2.2.0 RC1 (with the zip, also tried the .exe afterwards and didn’t notice any difference) on Windows 10 version 1709
What I try to demonstrate in this video is that opening a file with Audacity no longer fits the entire track in all cases. In previous versions of Audacity, after importing a file, it would always display it from start to finish. In 2.2.0 opening by double-clicking the file while Audacity is the default program, by right-click and Open, or by File > Open… doesn’t change the default zoom level (in the case of my screen from -1.0 to 20.5 seconds). However, when opening the track using File > Import > Audio or by drag-and-drop into Audacity, it fits the track normally.

Thank you for your support.

Thanks for the report. Same happens here, though really the “Open” command is intended for opening projects, whereas “Import” is for importing audio files.
I’m not sure if this new behaviour is intentional, and if so, what the thinking is behind it, I’ll ask and see if I can find out anything about it.

I’ve checked with the developers, and as I expected, it’s a bug.
It’s not considered so serious as to block the release of Audacity 2.2.0, but it will be added to the release notes in the Audacity wiki (currently being prepared here)

Completely off-topic, but relating to your video - one of the developers commented that he liked how you had put the meters at the bottom of the main window, and may start copying that himself :slight_smile:

The bug is in the final too. I hope it get’s fixed soon.

There’s always the option to use the “File menu > Import” command when you want to import audio files (rather than “File menu > Open”).

I usually use Drag & Drop.

Sorry for the extremely late response, but I stopped checking for replies when the thread was pushed off the first page. I just hoped someone had seen it and went on with my business. The rest is off-topic, but I wanted to let you know that I’ve noticed the reply.

I mainly use Audacity as an overkill music player so I just double-click to open a file most of the time. I may open and close Audacity dozens of times in a day; for songs less than 5 minutes long the loading time on my PC is negligible. I would complain about the exit confirmation dialog making me waste a second every time I do it, but it also saved me from hastily deleting a project once or twice. I often want to listen only to a certain part of a song, not from the beginning, so the bug is significant for me and I noticed it as soon as I opened a track with the new version. I need to Ctrl+F or click the appropriate button every time now. I’ll keep an eye out for the next nightly release and hopefully it will be fixed there.

Audacity is one of the programs that I always use maximized. I think that this toolbar arrangement I have now dates back to my first days of using it. The idea was to make the meters as long as possible, since with more space they would be perceived as more accurate. I found that I have enough space to stuff all of the buttons at the top and leave only the meters at the bottom.

You will be pleased to know that the bug has been fixed, and we’re aiming for a very short release cycle, with Audacity 2.2.1 being released early next month (assuming no unforeseen problems).

A good idea :slight_smile: I also do that when I’m doing actual audio work rather than testing / developing.